2 Replies Latest reply on Dec 6, 2017 3:13 AM by lynseyb88406597

    DRM registration mistake

    Ladyleeds Level 1

      I made a mistake when completing the DRM registration and now I can only download library books to read on my computer when I need to be able to read them on my Kobo Touch.

      Tried uninstalling and re-installing programme but that doesn't seem to work. Tried changing my password, that failed but I did get a message that said "You can only authorise this computer with an Adobe ID that hasn't previously been used to authorise any other computer or device.  Please try again"  - whatever that means!  Any advice please?  I am not a techie so any help needs to be easy to follow, thanks!

        • 1. Re: DRM registration mistake
          sjpt Level 4

          Sometimes ADE gets its registration/activation confused and in a semi-authorized state.

          Uninstalling and reinstalling does not help.

          Unfortunately, it often then gives misleading error messages about what is wrong.

          A common incorrect message informs you that the ID is already in use on another computer and cannot be reused.


          This can often be resolved by completely removing any authorization using ctrl-shift-D to the Library screen on ADE (cmd-shift-D if on Mac).

          Restart ADE, and then reauthorize with your (old) Adobe ID.


          • 2. Re: DRM registration mistake
            lynseyb88406597 Level 1

            Hi, I'm having a similar problem and was wondering once you enter cmd-shift-D it asks for password - what can I do if it won't accept my password (Adobe tell me it has had a glitch in their system and doesn't recognise it but they cannot offer me any help with this). Any suggestions would be appreciated.