7 Replies Latest reply: Aug 21, 2013 12:44 AM by Laubender RSS

    @ symbol shows as %40

    RepulseMonkey Community Member

      Hi, I'm using ID CC (V nice, thankyou).

       

      I'm creating hyperlinks to e-mail in ID then exporting to interactive pdf.  When open the pdf and hover the cursor over the link the @ symbol shows as %40.

       

      Plus, where spaces occur in the subject header they become %20.

       

      If I don't add a subject (I'd prefer to have a subject header), the e-mail address appears OK.

       

      Any clues?

       

      All help greatfully received.

       

      Thanks RP

        • 1. Re: @ symbol shows as %40
          JoaoCP Community Member

          This is absolutely normal. Internet links can only contain ASCII characters and cannot contain spaces. To work properly in URLs, some characters must be converted to the format you mentioned (the % sign plus two hexadecimal digits).

           

          Here you get a short (and much better) explanation: http://www.w3schools.com/tags/ref_urlencode.asp

          • 2. Re: @ symbol shows as %40
            RepulseMonkey Community Member

            Hi, thanks for the note.  I kinda guessed as much.  But I'm told there's a solution to the problem?

             

            When I apply a "_" in place of a space in the subject header the subject, at least, appears 'normal'.  But the e-mail address still has "%40" in place of the @ symbol.

             

            I can't understand why the e-mail address appears 'correctly' when I remove a subject line...  very strange.

             

            Thanks agian for taking the time to add a comment – appreciated.

             

            RP

            • 3. Re: @ symbol shows as %40
              JoaoCP Community Member

              My apologies. I misread your first post and thought you're referring to general Web links.

               

              I've just made a test using this hyperlink:

               

              mailto:info@example.com?subject=this is a subject

               

              The result varied depending on the PDF viewer:

               

              • Acrobat Professional 8 displays the link correctly (without %nn codes) and, when the link is clicked, opens a new mail message with the respective fields properly filled in.
              • Mac OS X Preview application and Safari don't show anything at all when I hover the cursor over the link, and don't create an e-mail messages when I click it.

               

              If I use this format instead:

               

              mailto:info@example.com?subject=this%20is%20a%20subject

               

              • Acrobat Professional 8 displays the link as is (with "%20", not regular spaces). However, the new e-mail message is filled in with regular spaces in the subject field.
              • Safari and Preview  display the subject header with regular spaces when I hover the cursor over the link. Clicking the link creates a well formed mail message.

               

              Due to theses discrepancies, I suggest you to test your PDF in more then one application.

              • 4. Re: @ symbol shows as %40
                RepulseMonkey Community Member

                Thanks for the feedback.  I'll do some more testing.

                 

                RP

                • 5. Re: @ symbol shows as %40
                  RepulseMonkey Community Member

                  Hi, just thought I'd drop you a line.  I've found the solution.  well, there's two options....

                   

                  1) Add the links AFTER you've made the pdf using Acrobats advanced editing tools.

                   

                  OR

                   

                  2) Add the links etc in InDesign, then edit the links in Acrobat (removing the the offending '%40' etc) and re-save the document.

                   

                  Sorted.

                   

                  Thansk again for your input.

                   

                  RP 

                  • 6. Re: @ symbol shows as %40
                    JoaoCP Community Member

                    Thanks for posting your findings!

                     

                    It's really a pity that we couldn't find a real solution to the problem. Let's hope that a future ID (or Acrobat) update solves this issue once and for all.

                     

                    Cheers!

                    • 7. Re: @ symbol shows as %40
                      Laubender MVP

                      2) Add the links etc in InDesign, then edit the links in Acrobat (removing the the offending '%40' etc) and re-save the document.

                       

                      @RP – in InDesign CS6 and CC this mess is due to a bug, that did the wrong encoding. CS5 and below is not affected.

                       

                      Solution in InDesign CS6 or CC:

                      You could change all the hyperlink URLs destinations  document wide with a script snippet like that (ExtendScript/JavaScript):

                       

                      Why does indesign escape my hyperlinks?

                      http://forums.adobe.com/message/5567691#5567691

                       

                       

                      For the details what is exactly  going wrong (a bug discription) look here.
                      I analyzed the problem in answer #1 of this rather lengthy thread:

                       

                      CS6 hyperlink problem

                      http://forums.adobe.com/message/4463255#4463255

                       

                      The mentioned script snippet in the first link above is by Peter Kahrel (changed a little bit by me). It is more radical and more elegant in solving the problem than my original script in the second link posted here in answer #1 (also marked correct) or an expanded one later in the same thread.

                       

                      I tested both scripts, however, use them with caution. That means, execute it on a duplicated InDesign file, that leaves the original intact…

                       

                      Uwe