2 Replies Latest reply on Aug 10, 2006 9:58 AM by PMCDEV

    Link Controls Problem

    PMCDEV
      I am using RoboHelp HTML X5.0.2 and Word 2003 on Windows XP platform. Topics are created in Word 2003 and then link controls (See Also, Related Topics, Keyword Search) added in the WYSIWYG editor. Everything works fine until a topic is subsequently edited in Word 2003 after which all the link controls "disappear". The controls still show up in the WYSIWYG editor but will not work until I re-do the links. I am in the early stages of a huge project and am testing various options to see how future changes can be managed. The odd thing is that the first time I tried the procedure on a topic with Related Topics link I saw a large red "X" in Word and a topic with a Keyword Search link appeared to be unaffected. This makes me wonder if there is a setting in Word which can be adjusted to prevent this problem. Has anyone else encountered this issue? Does anyone have any suggestions?
        • 1. Re: Link Controls Problem
          RoboWizard Level 4
          Hi PMCDEV

          Apologies in advance if my question borders on the asinine or rude. But I have to ask.

          You are generating WebHelp, so why are you using Microsoft Word as your editor? WebHelp is HTML based output, so I would think you would want to use an editor more closely matched to what you are creating.

          Cheers... Rick
          • 2. Re: Link Controls Problem
            PMCDEV Level 1
            Hi Rick,

            Actually your questions is quite reasonable but I just spent a considerable amount of time explaining how I came to be using this method when everything "disappeared" aos I will have to start over!

            Currently, our reference and training documentation (which is created and maintained in Lotus Notes) is provided to our clients in the form of multiple printed binders. The goal is to now provide all this documentation on a single CD. Since the software we are documenting runs on a Unix platform and our clients have a wide mixture of computing environments, WebHelp seems like the best output format.

            The easiest means of exporting the documents from Notes is as PDF’s and since RoboHelp can import PDF’s it seemed like the best tool for the job. However, when the documents are imported into RoboHelp everything is fine except for the tables. Unfortunately, all of our screen prints are in table format and all of the spacing is stripped in the tables which makes the screen prints unreadable and useless. (We are talking about hundreds of documents and probably thousands of screen prints!) The problem seems to lie with the conversion process from PDF to HTML as I tried various other conversion tools and all had the same results.

            My first solution was to bring the PDF documents into RoboHelp as baggage files. Although a fairly tedious and time-consuming process, it seemed like the answer but there are a couple of major drawbacks. First of all, linking cannot be done at the document level to cross reference between reference and how-to documents. (I was able to work around this to some extent by creating navigation topics for each software module which could be linked to each other to provide linking at a “group” level.) But the biggest deficiency is the inability to do full-text searches which would be a major advantage of changing to the electronic format.

            At this point, since I already had exported the documents as PDF’s, I considered using Adobe Acrobat instead of RoboHelp but this did not turn out to be a workable solution.

            So, I decided to return to RoboHelp using a different method of getting the documents out of Notes. Notes can export documents to RTF format but it means opening each document individually (whereas multiple documents can be exported to PDF from a “View” without opening each document). I tried various methods including opening the RTF document in Word and saving as HTML (formatting got messed up), opening the RTF document in Word, saving as DOC and importing into RoboHelp (way too cumbersome a process when each document is separate and even using RoboHelp for Word to import the RTF documents directly (didn’t like it – sorry – and also had formatting issues).

            Finally, I devised a method of creating the topics (in RobobHelp TOC) using Word 2003. I would then copy the contents of the Notes document, paste into the Word topic and save it. (I did try pasting contents directly into WYSIWYG editor but all formatting was lost – which is why I am using Word!!!) Although that may sound tedious, time consuming and cumbersome, it actually took about the same amount of time as using the baggage file method and, more importantly, it worked great! Topics look fine, full-text searches work and links can be placed on individual documents for cross referencing – which of course needs to be done in the WYSIWYG editor.

            Before proceeding too far, I decided to test what would happen in the future when documents need to be replaced with updated versions. And that brings us to my current problem. If a document containing link controls is edited in Word, the link controls added in WYSIWYG will no longer function. It seems like the only way to fix this is to re-open the topic in the WYSIWYG editor, actually re-do at least one of the links and then re-save the topic.

            Sorry for this lengthy response but perhaps you will have a better understanding of why I am experiencing the problem. I am open to suggestions if anyone knows of a better approach to this project.

            Thanks.