0 Replies Latest reply on Aug 22, 2013 6:02 PM by nivarc

    Japanese charset with cfdocument

    nivarc

      Hi, I know this problem has happened before, but after all the research and follow all the things I can do, I still stuck.

      so this is my code:

      <cfquery>

      select a, b

      from table 1

      </cfquery>

       

      <cfdocument format = "flashpaper">

      <cfoutput>

      #a#, #b#

      </cfoutput>

       

      Nothing fancy. however, a and b are in Japanese font. the HTML file display the character just fine, as do the excel format.

      I change my jvm.config with "-Duser.language=ja -Duser.region=JP". I also edit the cffont.properties to be the same with cffont.properties.ja

       

      I also install the Japanese support fornt pack for the server using "yum install "@Japanese support"

       

      on Adobe reader, I also install Asian support language pack.

       

      The result still the same when I run the code, the japanese character returns as boxes.

      I am not sure what else to do so my character come out correctly.

      I am using Centos 6, coldfusion 10 - developer edition, and postgres 9, my database has UTF-8

      Any suggestion? PLEASE!!!