8 Replies Latest reply on Feb 23, 2017 2:50 PM by CreeDeaux

    How do I get InDesign CS5 to stop changing my font to Minion Pro?

    TigerhawkT3

      With no document open, the font says Times New Roman, so that should be the default. However, pasting text into a text box from another program like Open Office Writer and then adding a carriage return (normal Enter, not Shift+Enter) causes the font to suddenly change to Minion Pro, so anything I type or paste in at that point is in Minion Pro. I'm getting tired of constantly opting out of InDesign's favorite font. What do I have to do to get InDesign CS5 to accept that I use Times New Roman and not Minion Pro?

        • 1. Re: How do I get InDesign CS5 to stop changing my font to Minion Pro?
          Peter Spier Most Valuable Participant (Moderator)

          You can try editing the [Basic Paragraph] Style.

          • 2. Re: How do I get InDesign CS5 to stop changing my font to Minion Pro?
            1tice2001 Level 1

            Yes, but that's not a good idea to edit [Basic Paragraph]. Even David Blatner says to leave [Basic Paragraph] be.

             

            Simply create a new Paragraph Style as your preferred default.

             

            In case you don't know, the way to do that is to open InDesign from it's applicaiton icon, and from that empty interface (in other words, don't create a new page, and don't open InDesign from a recent document), Opt/Alt click the new paragraph style button and create you new default style and give it a name. From thereonin, every time you open InDesign, your new style will be there in the palette below [Basic Paragraph]

            • 3. Re: How do I get InDesign CS5 to stop changing my font to Minion Pro?
              Peter Spier Most Valuable Participant (Moderator)

              The only problem with editing [Basic Paragraph] is that the text will change to match a different definition of [Basic Paragraph] when you move it to a new file with a a different definition. This in no differnt thatn waht would would happen with a style named Body Text, or any other name. The only reason it pops up is that by default every documten since CS3 (or maybe even earlier, I've long forgotten) has a stle named [Basic Paragraph], and unless the user adds another style that's waht all text will use.

               

              I don't recall what Mr. Blatner said about [Basic Paragraph] and it's actually irrelevant as long as you know how styles work, and how "based on" styles can be affected. Most users I know will tell you never to base another style on [Basic Paragraph] because it can have unintended effects when moving between files, precisely because users are free to use any definition of [Basic Paragraph] that they choose.

               

              A new default style is fine, but it certainly isn't required.

              • 4. Re: How do I get InDesign CS5 to stop changing my font to Minion Pro?
                TigerhawkT3 Level 1

                It looks like Paragraph Style is where the problems are coming from. However, opening ID on its own and making a new paragraph style did not solve the issue, because as soon as I open a document, the style I made disappears from the list. So I made the new style while already within an existing document, and that makes ID no longer revert to Minion Pro. Unfortunately, it looks like that just makes it choose something different to revert to. If I choose anything different from the font/size/etc. specified in the current paragraph style - say, if I want Tahoma 12 for a little bit instead of the usual TNR 11 - it'll add a "+" next to the style in the paragraph style window, and tell me that the style is currently being overridden by whatever changes I chose, and I can alt-click to clear it. I paste something in, press Enter... and the "+" disappears, with the style overrides (i.e., the font/size/etc. changes I specifically chose a few seconds ago) gone.

                 

                Is there a way to tell InDesign to just keep whatever font/size/etc. I've chosen at any given moment, even after I paste text in and then put in a carriage return?

                • 5. Re: How do I get InDesign CS5 to stop changing my font to Minion Pro?
                  Ellis home Level 4

                  That's just the way Indesign works. I think you need to get more familiar with the way ID functions. Many people here recommend Sandee Cohen's book Visual Quickstart Guide as a good start. Peter already gave you an answer regarding changing the default font to what you want. Any new document will start with just one paragraph style: Basic Paragraph. You are suppose to create (or import) the styles you need in your document.

                  • 6. Re: How do I get InDesign CS5 to stop changing my font to Minion Pro?
                    Peter Spier Most Valuable Participant (Moderator)

                    Let's see if we can explain this better...

                     

                    Here's what I think is happening based on what I've been able to do here to reproduce this.

                     

                    First, in the Clipboard Handling prefs the setting is to paste text only, not All Information. The TNR setting is a local override to Basic Paragraph which has been set as the default in the character panel or control panel, but [BP] itself is still set to Minion Pro.

                     

                    You can type all day in ID with settings like this and not have the font change to Minion Pro, so it is tied to the paste settings. I think what is happening is that ID must ignore any formatting in the copied text in order to make the pasted text match what is set at the cursor position and for some reason resets the default text attributes to the paragraph style definition, so when you press enter your local override default is gone, but only for that frame. I believe this is actually using the Paste Without Formatting command.

                     

                    It doesn't seem to matter if you continue to type in the same paragraph, the next one loses the override. You can make this happen using the Paste Without Formatting command after copying text you type with your default settings as an override, as well, even if the format of the copied text is already exactly the same because you typed it in the same paragraph. The trigger for this though, is the position in your text where you paste -- it only happens when you paste at the end of the existing text in your story.

                     

                    I'm not sure if this is a bug or intended behavior, though I'm leaning towards the latter as it makes some logical sense to me. Paragraph formatting for the next paragraph is picked up from the last character when you press enter as you type at the end of a story, whereas if you type on the end of an exisiting paragraph in the middle someplace, the break at the end of that paragraph is already formatted.

                     

                    Bottom line, I think the only way to make your workflow work is to make a default paragraph style with your TNR formatting eihter by editing [BP] or making a new one. I'm not sure why you didn't have success with a new style. Did you create the new style with nothing open? Did you set the formatting to be TNR? Did you also be sure to highlight this style with nothing open so that it was set to be the default?

                    • 7. Re: How do I get InDesign CS5 to stop changing my font to Minion Pro?
                      Peter Spier Most Valuable Participant (Moderator)

                      What I said above is is accurate for the condition described -- clipboard handling set to text only, but there are other scenarios that might be worth exploring. First would be the clipboard handling setting. If the text is already formatted in Word the way you want it, changing the setting to All Information would result in the next paragraph picking up that format from the Word text rather than reverting to [Basic Paragraph] without overrrides.

                       

                      But the bigger question in my mind is if the copy/paste workflow is actually the best method for what you are doing, and why you don't use File > Place... Are you grabbing random chunks of text from multiple files, lots of chunks from one file, all of the text? There are lots of options available for preserving or discarding formatting or mapping to new styles in the Import Options when you place instead of paste.

                       

                      I do a newsletter for one client where the articles are authored by various different members of the organization whose skill level in Word ranges from the pathetic to the not-so-good. Lots of the articles have been styled in odd ways to make them "look good" or make some sort of organizational sense to the author, but they have no resemblance to the styles actually used in the newsletter. I usually place these as-is in ID and fix the formatting there by applying my styles or running scripts to remove stuff that doesn't belong. I find that much faster than anything else I've tried, even if I'm going to copy/paste from the fixed text in a frame on the pasteboard to get it into position in the document layout.

                      • 8. Re: How do I get InDesign CS5 to stop changing my font to Minion Pro?
                        CreeDeaux Level 1

                        Several years later I am annoyed with this too so I thought I'd share what I figured out.

                         

                        If you change settings with no document open, or when the settings wouldn't normally apply, ID is supposed to remember those settings and use them in future new documents. But if you change your default font this way, your paragraph style overrides it. But you only see this once you start a new paragraph AFTER the first one.

                         

                        So say you open indesign with no document, choose the text tool, change your default font to Times, and then close. If you then reopen indesign and glance at your basic paragraph style, it will probably show a + next to it indicating a local edit. So when you paste your first blob of text, it's in times. But then you hit enter, and the default paragraph style (without local edits) takes over. Now you're back in Minion.

                         

                        So the first thing is run indesign, don't open any document, choose your text tool, change the font to Times or whatever non-minion font, and change the size etc. if you want too. Do this in the character styles panel too. You might also change any table or cell style defaults while you're at it.

                         

                        Only after changing these settings, should you open your paragraph style panel. Look for the [basic paragraph] style, and if you see a + symbol indicating local overrides, alt+click it to clear them. Then right click, edit the default, and choose your preferred font and size. Then close ID without opening any document to make sure the settings stick. Now the paragraph style won't show a + next to it, and every paragraph gets the font you prefer, not just the first paragraph.

                         

                        Where it gets annoying is... that if you open an existing older file that had the annoying Minion font as its [basic paragraph], that setting overrides your defaults. Pretty much all settings will do this. So if you have lots of older documents that you need to use as a basis for new documents, it can get frustrating. Like if you open the 2015 version of a file, do Save As... and make a 2016 version... and then use that as a starting point, you'll be stuck with your old styles and preferences from 2015. One solution that might be easier than changing them all back, is to just open a new document, then copy and paste everything from the old document into the new one. If it's not a ton of pages you can probably just do select all, ctrl+G to group, then copy and paste in place. Your new styles will be in effect.

                         

                        Finally, I found a pretty good solution for style conflicts (like copying from word or some other adobe program, and having indesign preserve unwanted styles when you paste). For windows anyway... it's just a simple app called PureText+ that runs constantly in the background (in the system tray, where your volume, clock, etc. are). When you want to paste and keep formatting, you do the usual keyboard shortcut (ctrl+V). When you want to paste as plain text (so your indesign default formatting takes over), you just do [windows key]+V which is right next door to ctrl+V. It won't take long for this to become second nature.