7 Replies Latest reply on Jan 17, 2008 12:57 AM by Peter Grainge

    robopox

    lcjohn
      I've installed RH7 and opened a large project created in RH5. On some pages, the javascript now appears as red boxes in the RH wysiwyg. I have no idea why this affects only certain pages. Also, columns have disappeared from a large table. I had a similar problem with 'robopox' years ago in RH5; someone suggested a solution, but I can't remember it.

      Thanks, John
        • 1. Re: robopox
          Peter Grainge Adobe Community Professional (Moderator)
          Sometimes javascript will appear as a red square. There are various methods on my site that use javascript that will do just what you describe. Those scripts will always do that in any page so is the point here that the same script appears as a red square in some topics and not others or is it specific scripts that do it?

          I am talking here of your own javascript. If it is RH's own javascript, that should not appear.

          Are the red squares in the same position? Where?

          Let us know more.

          Not sure about the columns. Do they display in Preview?

          • 2. Re: robopox
            lcjohn Level 1
            Thanks Peter: it's RH's js - and it's kadov stuff that I thought was supposed to be a thing of the past! Here is an example:

            <script type="text/javascript" language=JavaScript1.2><!--
            kadovFilePopupInit('a13');
            //--></script>

            - and, yes, I can see the columns in preview, but I can't find them even in the html, which seems totally bizarre, so it's impossible to edit this file.
            • 3. Re: robopox
              Peter Grainge Adobe Community Professional (Moderator)
              It is theoretically possible you will find traces of kadov within javascript but that is within standards. There are no more kadov tags. That said, I haven't encountered kadov so far.

              That looks like the script for a popup that didn't get upgraded. Was the X5 project local when you upgraded? Do you have a copy of the project before it was upgraded?

              Try the following.

              Open a topic, make a small change, save, close and reopen the topic. Any change.

              Import one of these topics into a new RH7 project.

              Double click one of the popups and change the setting. Then reapply the popup setting.

              Does any of that work?

              We'll come back to the columns after dealing with this one.

              • 4. Re: robopox
                lcjohn Level 1
                Sorry, Peter: are you suggesting that I make the 'small change in RH5 and then import into EH7? My topic pages have multiple links which would be lost. I've made changes, saved, closed and reopened, all in RH7 without any effect - the red pox are still there.

                John
                • 5. Re: robopox
                  Peter Grainge Adobe Community Professional (Moderator)
                  No. There were three things to try.

                  Open a topic, make a small change, save, close and reopen the topic. Any change?
                  ### Do that in RH7.


                  Import one of these topics into a new RH7 project.
                  ###
                  Import one of the problem topics from the X5 project into a new RH7 project?

                  Double click one of the popups and change the setting. Then reapply the popup setting.
                  ### In RH7. Both the old and the new (if you still get the problem in the newly imported topic).

                  • 6. Re: robopox
                    lcjohn Level 1
                    OK, I've tried this, but still see the red boxes, and the src doesn't seem to have changed.

                    • 7. Re: robopox
                      Peter Grainge Adobe Community Professional (Moderator)
                      OK. So you have a new project with just one or two topics that has this problem. Zip it up and send it to me via my site. I will look at it later.