0 Replies Latest reply on Aug 27, 2013 2:06 AM by catelizabeth

    Oops! This document couldn't be opened!

    catelizabeth

      I'm so frustrated that I am not able to open ebooks on my new KoboGlo. I followed all the instructions for setting it up and ADE shows that both my computer and device are authorized, but when I try to open a book that I downloaded from the library the following message pops up on my Kobo, "Oops! This document couldn't be opened. This document is protected by Adobe Digital Rights Management (DRM) and is not currently authorized for use with your Adobe ID. Please sign-in with the authorized Adobe ID and try again." I have no idea what to do with this. There is no issue with downloading the book to my ereader or opening it on my desktop, I just can't open it on my Kobo.

       

      I have tried uninstalling and reinstalling both ADE 2.0 and 1.7.2 a couple of times, as well as resetting my KoboGlo, and downloading different books, but still get the same results. I also searched the Adobe website for a tech support number, finally finding one for Adobe Connect (?) and decided to give it a shot. After waiting on hold for almost 2 hours, struggling with a bad connection and a person who was difficult to understand, I eventually explained the problem and what I had already tried to do to resolve it, then verified who I was with my account info, only to be told me that he wasn't qualified with this software and would have to get someone to call me back 'some time'. I'm not getting my hopes up for this.

       

      I didn't have any of these issues with my original Kobo, and am beyond frustrated at this point! I just received the KoboGlo as a birthday gift and would really like to be able to use it. If anyone can help me, it would be greatly appreciated!

       

      Thanks.

      Cat