6 Replies Latest reply on Jan 16, 2008 9:57 AM by Karen Graf

    Topic templates not importing to Robo 7 successfully

    Karen Graf Level 1
      We are trying to update from RoboHelp 2002 to RoboHelp 7. Everything seems to work fine when I import the RoboHelp 2002 HHPs into RoboHelp 7. However, the topic templates (HTT files) are missing from the Templates folder in RoboHelp, and they are not available in the New Topic dialog box Template drop-down.

      When I'm in the New Topic dialog box, I can use the Browse button to go out and choose a template, but that won't copy the template into my project, it only applies the template to the current topic and does not make the template available for future new topics.

      I can see the template files when I use Windows Explorer to look into the root directory of my project, but I can't get them to show up in RoboHelp even when I use the Import Templates feature.

      Any help will be greatly appreciated.
      Karen

      P.S. I am working locally (never on a network!).
        • 1. Re: Topic templates not importing to Robo 7 successfully
          Captiv8r Adobe Community Professional & MVP
          Hi Karen

          One thought I had that you may wish to try would be as follows:

          Move the templates to a different folder. Then, from inside RoboHelp 7, right-click the Templates pseudo folder and choose "Import...". Navigate to and select the templates and see if RoboHelp 7 is finally happy and adds them to the project.

          Give that a go and keep us posted on the outcome.

          Cheers... Rick
          • 2. Re: Topic templates not importing to Robo 7 successfully
            Karen Graf Level 1
            Thanks Rick. I'll give that a try either tonight or tomorrow night and let you know.

            Has anyone else come across this problem?

            Karen
            • 3. Re: Topic templates not importing to Robo 7 successfully
              Karen Graf Level 1
              Hi Rick,

              No luck. I moved all the templates to a different folder, right-clicked the pseudo Templates folder in RoboHelp's Project Set-up pane, and imported one of the templates. It looked like it worked. The Confirm Overwrite dialog appeared, prompting me to overwrite all the files associated with the template (js, jpg, css, etc.). I clicked OK, and nothing happened.

              The template was not added to the pseudo Templates folder, and did not appear in the New Topic dialog's Template drop-down. However, when I checked the project folder using Windows Explorer, the template was added to the root of the directory....just as if I had never moved it to begin with.

              I can create new templates from within RoboHelp 7 and they appear in RoboHelp just fine. I can also create a new topic based on one of my imported templates, but I always have to browse out of the New Topic dialog box to choose the template. Then the new topic is based on the template I chose, but the template is still not showing up anywhere within the RoboHelp interface.

              I'm a bit baffled. Any other ideas?

              Karen
              • 4. Re: Topic templates not importing to Robo 7 successfully
                Karen Graf Level 1
                Hi again,

                One more note. If I keep the templates in the project’s root directory and import one of them using the pseudo Templates folder, it looks like it works. The Confirm Overwrite dialog appears, and one of the files it prompts me to overwrite is the template itself! I choose OK, but to no avail. The template is still not available through the RoboHelp interface.

                It’s almost as if RoboHelp’s database “sees” the template, but won’t allow me to access it through the UI.

                Karen
                • 5. Re: Topic templates not importing to Robo 7 successfully
                  LaKisha1 Level 1
                  Hi Karen,

                  Yes, I have had the same problem a few times. I've called technical support about it and the only solution was to rename all my templates, then import them. I know just what you mean by "sees the template, but won't allow me to access it through the UI."

                  In general, RH has serious problems with templates in my opinion (and I hope template enhancement is at the top of the list for the next version!). Every time I update a template and then save it (I use them a bit differently than what is intended), I get that fatal error that makes RH close. When I reopen RH, it has saved my changes, so I'm good to go. But I think that what's happening is that when it searches my files to apply the updates that I made, RH encounters problems because my updates are not in the places that RH expects them to be (header and footer). If you are familiar with Dreamweaver, I sort of use the templates like that - there's a lot of text already in them, so that when I create a new page, most of the text that I need is already in the body of the html page. Now if Adobe would just allow us to designate editable and non-editable regions like in Dreamweaver...

                  lol, sorry for the digression! Templates are a hot button for me.
                  • 6. Re: Topic templates not importing to Robo 7 successfully
                    Karen Graf Level 1
                    Hi LaKisha1,

                    Thanks for your reply. I'm no novice when it comes to RoboHelp.....I've been writing help systems for well over 10 years. I am grateful to know that someone else has experienced this. Adobe's Tech Support response is a bit disapointing. Did the person you worked with mention whether or not this has been logged as a bug or maybe even an enhancement request?

                    When you renamed your topic templates, did anything happen to the imported topics that were based on the original template file names? We may have to keep the old template files and add new templates created by copying and renaming the original templates. Maybe it would be cleaner just to re-create the templates!

                    Anyway, thanks again.
                    Karen