6 Replies Latest reply on Dec 18, 2013 7:27 AM by cdavis289

    Sapphire HD 7950 OpenCL/GL Support

    cdavis289

      I recently updated my Mac Pro 4,1 with the relatively new Sapphire AMD HD 7950 card for Mac. However, it looks like OpenCL and OpenGL support from CC is not yet available for this card, regardless of its ability to support high-intensity programs that utilize OpenCL/GL. Will this card ever get the support from Adobe so that I can fully utilize its strength?

        • 1. Re: Sapphire HD 7950 OpenCL/GL Support
          petergaraway Adobe Employee

          Hi there,

           

          I just gave this response to another user. Though I can't speak to if/when the 7950 will be supported I can tell you (and you may already know this) that you can enable the Mercury Playback Engine with the 7950 in Premiere Pro CC.

           

          New in Premiere Pro CC. As long as you have a reasonably modern card with at least 1GB of VRAM, you will still be able to enable that card in the Project Settings dialog. A warning message will appear letting you know that your card has not been certified by Adobe, but once that dialog is clicked through you can use your GPU. The team does try to certify as many GPUs as possible, but we can’t test everything, so this is a way to let you decide if you’re happy using an untested configuration.

           

           

          All the best,

           

          Peter Garaway

          Adobe

          Premiere Pro

          • 2. Re: Sapphire HD 7950 OpenCL/GL Support
            cdavis289 Level 1

            Well, it seems like Adobe just updated their list. However, with or without its support, every time I try to use GPU acceleration, my playback display grays out and my program monitor doesn't display anything.. Will try to update the GPU's driver (though I'm 99% sure it is up to date) but if I could get additional help, that'd be awesome. Thanks!

            • 3. Re: Sapphire HD 7950 OpenCL/GL Support
              spidervideo

              I'm having the same issue with the gray-ing out.  When I switch back to CPU only the video reappears so I'm wondering if I'm simply missing a setting somewhere or a driver/update.  On the US site it does list this card as compatible: http://www.adobe.com/products/premiere/tech-specs.html

              • 4. Re: Sapphire HD 7950 OpenCL/GL Support
                spidervideo Level 1

                Solved it in my case.  I ran into another thread about competing GPUs causing conflicts.  I had a second older graphics card also installed.  I took the other older card out and now everything works fine!

                 

                Hope that helps

                 

                Craig

                • 5. Re: Sapphire HD 7950 OpenCL/GL Support
                  spidervideo Level 1

                  Solved it in my case.  I ran into another thread about competing GPUs causing conflicts.  I had a second older graphics card also installed.  I took the other older card out and now everything works fine!

                   

                  Hope that helps

                   

                  Craig

                  • 6. Re: Sapphire HD 7950 OpenCL/GL Support
                    cdavis289 Level 1

                    Thanks 5.spidervideo! I too had an older card plugged in above the Sapphire. I took it out the other day but have not tested to see if it resolved my issue. I'll sound the alarm again if it doesn't work. If I'm silent, you'll know all is well...