0 Replies Latest reply on Jun 9, 2006 10:41 AM by I tried

    Undefined problem when attaching swf

    I tried Level 1
      Hi all,

      I am trying to complete what should be a pretty standard activity, but am having many problems. The basic premise is this. I have a container swf whose job is to load data via remoting and then based upon that data build other swfs and then populate them with that data. The container swf works fine for the first half. Here is the code I use to attach the movies (using test data here, eventually I'll use a for loop to do this many times).

      var aListings = new Array();
      var mcl = new MovieClipLoader();
      var mc = this.createEmptyMovieClip("listing" + i, getNextHighestDepth());
      mcl.loadClip("/Listings/AdminListingsGrid/templates/GridTemplate5Test.swf?ListID=0", mc);
      aListings.push(mc);

      I'm creating an array, then a movie clip loader. Creating an empty movie clip then loading it with an external swf, sending a little data along as well. The external swf is controlled by an actionscript class as well. Then I'm adding the clip I loaded to an array for easy reference when populating the data. The trouble I'm having is that I can't seem to access any of the public methods of the new object. I trace them out and they are simply not getting called. I've added x-ray to the container class and noticed that the object I'm adding keeps picking up an undefined Class property. It will say undefined.movieclip.object, while all other objects will say something like com.blah.blah.movieclip.object. Anyone run into this before or have ideas on what I can do? Help is appreciated in advance.

      Thanks
      Robert