5 Replies Latest reply on Jun 11, 2006 4:47 PM by kglad

    Published Movies Link to Old Source

    beevyarr
      Working in Flash 8, publishing Flash 6. Optimized for FPlayer 6r.

      Having published before with numerous changes, I made simple link changes to button code that will no longer publish.

      Example:
      Original Code on Button Instance:
      on (release) {
      getURL("pdfs/"+prodID+".pdf", "_blank")
      };

      With this code, everything worked. I then moved the files to a new location to make them absolute on the server, in the root folder.

      New Button Code:
      on (release) {
      getURL(" http://www.website.com/pdfs/"+prodID+".pdf", "_blank")
      };

      Not working. I moved the code entirely into actionscript (for better practice anyhow) as this:

      pdf_btn.onRelease = function() {
      getURL(" http://www.website.com/pdfs/"+prodID+".pdf", "_blank")
      }

      Not working. The movies continually try to download from the original RELATIVE location coding.

      I'm stumped. I've even published after deleting ASO Files (which I don't have). No luck. The published movies continue to download from the old source. Suggestions?
        • 1. Re: Published Movies Link to Old Source
          Wolf_van_Ween Level 1
          Did you change something else in your swf, that allows you to judge whether you're using the new version of the swf at all?
          Or could you still be looking at a cached version? (of the swf, not the pdf)
          Just a try ...
          • 2. Re: Published Movies Link to Old Source
            beevyarr Level 1
            Good advice, but I've cleared web & system caches to no avail. This is possibly the most perplexing situation I've come across.

            And yes, I did make some other cosmetic changes that are updated in the published versions. My only suspision is that I have recently downloaded an InDesign CS2 trial that may have futzed up other Adobe programs, but realistically I don't see that as the problem.
            • 3. Re: Published Movies Link to Old Source
              Level 7
              2 days ago i had the same problem, i empty the browser cache, delete the
              old file in the server before uploading the new version,
              closed/restarted the browser/OS, ... but no way. i needed to move to
              another machine in the same room to see the changes

              so, my only guess there's a bug in the browser/OS cache cleaning

              beevyarr wrote:
              > Good advice, but I've cleared web & system caches to no avail. This is
              > possibly the most perplexing situation I've come across.
              >
              > And yes, I did make some other cosmetic changes that are updated in the
              > published versions. My only suspision is that I have recently downloaded an
              > InDesign CS2 trial that may have futzed up other Adobe programs, but
              > realistically I don't see that as the problem.
              • 4. Re: Published Movies Link to Old Source
                beevyarr Level 1
                I really don't feel that this is a browser cache issue. Flash is actually publishing the swf without the code change. This has to be something within the program that I'm missing.
                • 5. Re: Published Movies Link to Old Source
                  kglad Adobe Community Professional & MVP
                  are you using #include for any of your actionscript? if not, flash will publish with the code changes. you can decompile your swf and check or add a textfield and check.