2 Replies Latest reply on Aug 31, 2013 9:19 PM by pwillener

    Which version of Flash Player?

    Live4Dogs

      I am using a MacBook Pro, with OSX10.5.8 and continue to get messages from Foxfire (preferred browser) that I have no Flash Player and that I can't use the most recent one, check the arhives for one that works with my old machine.  Since I am not good at sorting this out, I don't know what to look for or what to download.  This is not an Intel based machine.  Thanks for your help.