10 Replies Latest reply on Oct 4, 2013 9:12 AM by Josh_Corey

    How to remove "Local Host" Riboon from form

    carolakashorty Level 1

      Hi ,

       

      I have embedded my form into an html file so that the grey background will not show and its coming up with a "Local Host" Yellow ribbon in the left hand corner.

      The form file is being viewed by customers so that ribbon makes it look very unprofessional.

       

      What can i do to remove this ribbon?

      Do i have to upload my html file somwhere?

       

      At a bit of a loss here.

       

      Any help would be appreciated and Thanks in advance.

       

      KJW

        • 1. Re: How to remove "Local Host" Riboon from form
          Josh_Corey Adobe Employee

          Hi;

           

          As long as a web site is being developed and tested locally this is expected behavior.  Once your web site is uploaded to and hosted on a server you would not see this banner. 

           

          All you have to do is to use the embed code that we provide and once the site is on a server and not local it will not display the banner.

           

          Thanks,

          Josh

          • 2. Re: How to remove "Local Host" Riboon from form
            carolakashorty Level 1

            Hello  and thank you for the response

             

            What i did was , i sent a site my embed code and the form will be in an iframe of 448x700.

            Now, when they embed the code , they grey bar shows at the top ( the background of the page behind the form).

             

            What i did was that i created an htl file with a table of the right size and implemented the form in such a way as to remove the grey buffer. Everything looks great except for that yellow ribbon.

            I have uploaded my html to the server in hopes that it then wouldn't be a local host but yet it is still there.

             

            So what you are telling me is that the only way to do this would be to just use the embed code and accept the fact that the grey is present in the background?

             

            I have attached my form in case that helps at all.

             

             

            Thanking you in advance

            • 3. Re: How to remove "Local Host" Riboon from form
              Josh_Corey Adobe Employee

              Yes, the only way to embed a FormsCentral form is using the provided embed code on the Distribute tab, but you should not have to have a grey background (or border or buffer?).  What is the grey when the Embed code provided was used in the iFrame? 

               

              You have options on the Distribute tab in the Embed section where the embed code is to "Include Background Colors" and "Inculde Form Header".  In your form you have control over the header color and the page background color, you can set those to whatever you'd like (or delete the header all together) and then have them applied in the embedded form or not using the options mentioned. 

               

              Here is a page of troubleshooting for embedded forms: http://forums.adobe.com/message/5655289#5655289

               

              If you are still having trouble could you go back to simply having the embed code inside the iframe and send me a URL to see at jcorey@adobe.com?

               

              Thanks,

              Josh

              • 4. Re: How to remove "Local Host" Riboon from form
                carolakashorty Level 1

                How do i change this grey background colour and stop the form form having a drop shadow ?

                 

                if i can change those two things it will fix the problem, but i can't seem to find the options

                • 5. Re: How to remove "Local Host" Riboon from form
                  cwclifford Adobe Employee

                  I also have the "Local Host" banner though I've used straight FC embed code many times before without this appearing. The only difference I can spot is that the form ID has a "%" in it for the one that's giving me trouble. Any chance this is a known issue?

                  • 6. Re: How to remove "Local Host" Riboon from form
                    Josh_Corey Adobe Employee

                    Are you still having this isssue?  I had started to respond and never finished, appologies for the delay.

                     

                    Thanks,

                    Josh

                    • 7. Re: How to remove "Local Host" Riboon from form
                      carolakashorty Level 1

                      Hi Josh ,

                       

                       

                      Thanks for the response. I didnt see any % signs in my coding so i couldn't see the issue you were talking about. Didnt try to fix it further since then but when i do i will get back to you.

                       

                      The form will look so much better with this issue fixed although i don't see the point of even having this yellow ribbon on there. would make life so much easier if we could get rid of it altogether

                      • 8. Re: How to remove "Local Host" Riboon from form
                        Josh_Corey Adobe Employee

                        Did we exchange email around this?  I don't recall the % sign discussion.  Are you saying you are still seeing the yellow ribbon when your form is embedded in a site that is live, running on a server?  That ribbon is only shown when you are running the site "locally".  If you can remind me of the email thread if we exchanged mail, or send me a link to the site at jcorey@adobe.com I can take a look.

                         

                        Had you taken a look again at the embed options in FormsCentral to check the background color setting there and what colors you can set in the form itself?

                         

                        Thanks,

                        Josh

                        • 9. Re: How to remove "Local Host" Riboon from form
                          cwclifford Adobe Employee

                          Hi Josh,

                           

                          I was the one who reported the "%" issue. We have many other embedded forms and we found that the one that shows "Local Host" has this slight difference in the Form ID. That's all we could determine and or some reason when we regenerated the form and got a Form ID that excluded the "%" it worked!

                           

                          So, this could be entirely on our end? Soemthing about the way we treat the "%" in a URL? But, this all appears in an iframe so it shouldn't be on our end?

                           

                          Thanks,

                          -Craig

                          • 10. Re: How to remove "Local Host" Riboon from form
                            Josh_Corey Adobe Employee

                            Hi Craig;  Thanks for clearing that up.  I wasn't reading your post today in response so I missed that.  We'll take a look at the % sign in the URL you found, I'll let you know if I learn anything.

                             

                            carolakashorty - it would be great if you could send a link to your form so we can help you get it right.

                             

                            Thanks,

                            Josh