7 Replies Latest reply on Feb 6, 2015 3:22 PM by marke38679877

    Lots of weird Single-Frame offset errors lately

    Willie Frazier Level 1

      Hi Everyone,



          I have been fighting some mighty germlins of late.  At first, I though the issue was isolated, but it appears to be spreading - or at least not as isolated as I first thought.


          The problems began when I was asked to employ the use of the CC Twister plugin on a project for use as a text transition.  When I initially set it up, it worked great, but I found I needed to adjust the timing.  When I dragged a keyframe to facilitate this, I found that the text would either not resolve where it should, instead animating up to the upper left corner (0,0) or if it didn't resolve there, it would simply pop up there for a single frame at some point during the transition.  I found that changing ANYTHING would cause this... even if I kept the timing alone and disabled the layer's track matte; and I didn't have to undo, I could just put the property back like it was and it would work again.  Obviously, I tried deleting the effect, and applying it anew - same results...   I then tried cleaning all the cache files, applying the effect anew once more, and again... same results.  There was no rhyme or reason to it... nothing that appeared to be driving the issue.  In fact, at one point I could RAM preview the comp, and it looked correct, but the problem would pop up again when rendering... despite changing nothing in the comp.  So, I simply had to presume that this effect had a bug of some sort, rendering it useless pending an update. 


           So then, last night, I had a similar issue during rendering with Trapcode Form.  Whenever I would do quarter or half res previews, things were working as expected... then I'd do a full res export and some of the forms would jump wildly from one frame to the next... always for just one frame, but often several scattered individual frames would be effected.  When I'd go back into the comp after the render, the errors were 'baked in' as though they has always been there... though they most definitely had not.  In this case, the issue started when I enabled multi-processing (it was never on in the first example with CC Twister above).  It occured to me that in THAT case, since one core might be rendering a frame two or three frames ahead of another core, and said core therefore perhaps didn't have the necessary data from the preceeding frame, the position would be incorrectly calulated.  A similar phenomenon occurs in C4D with certain generators when rendering out of sequence, necessitating baking of the solution.... Whether or not this is the case, the fact that the error actually affected the comp post render is really unsettling.  After turning off Multi-Processing, I was able to to export a clean full-res render without any issue.  So, I thought it odd that I was having similar issues with entirely different circumstances at play, but again had to assume these were isolated and that THIS issue was simply a matter of the notoriously unstable AE multi-processing rearing once more its not ready for prime time head.


           That brings me to today.  I was asked by my client to give a little subtle movement to the text layers in my scene.  I wanted to try a couple of things... a subtle wiggle on the text layer itself, or using the similar function from the plugin Sure Target, in case they wanted the movement to be on more elements than just the text, I could easily add new elements to the movement by making them 3D layers.  So I made 2 new comps to test, find the right settings, and decide if there was a technique I preferred.  On the text layer itself, I was able to apply the wiggle with some experession controls, no problems at all.  In my second comp, when I employed the use of Sure Target (which itself uses thw Wiggle Experssion with controls), I found that my text would, at some random frame, suddenly pop over to X-0, and nothing I could would prevent it. 


          So there it is... 3 different situations in the last few days... different variables at play in each one, but a similar issue.  The only commonality here is that all 3 issues involved 3rd party plugins, though all from different companies (Cycore, Red Giant, and Video Copilot), so maybe there is something to that... but there has to be more to it.


          My next step is to try and replicate these issues at home, just to rule out the very unlikely possibility that this machine is the culprit.


          Appogies for the length of this post - I know that will prevent some of you from reading it, but for those who do and can perhaps offer some theories or insights, I truly appreciate it.


      - Will


      FWIW the system I am using is a 2013 iMac 3.4GHz i7 with 16GB of RAM running OSX 10.8.4 and the latest version of Creative Cloud.