7 Replies Latest reply on Sep 9, 2013 4:38 AM by Peter Spier

    Spell-checking and language dictionaries

    community help Level 1

      This question was posted in response to the following article: http://help.adobe.com/en_US/indesign/cs/using/WSa285fff53dea4f8617383751001ea8cb3f-6f53a.h tml

        • 1. Re:  Spell-checking and language dictionaries
          TabithaSpottybott Level 1

          I'm struggling with the spell check function. I have repeatedly set the dictionary in Preferences to English:UK, but every time I try to check the document, the dictionary defaults to Portugese:Brazilian. I've tried changing the dictionary via the Edit command as well as in Preferences; I can set it to English:UK, but it only applies this dictionary to whichever word my cursor happens to be sitting next to, and applies Portugese:Brazilian to the next word in the story.


          The other odd thing is that the English words do actually appear to be in the dictionary, but it wants to change every single one of them like-for-like. So for instance, it suggests I change 'that' to 'that'. It won't recognise my 'that', even though it's spelled perfectly correctly. Every single word in the story is underlined in red, with the suggestion that I change it in this way; this is hardly an option, as there are 5000 words! The only way to do it at the moment is to copy and paste all the text into a Microsoft Word document to check the spelling – which is a bit of a pain, especially as the formatting isn't retained if I paste text back into InDesign.

          • 2. Re:  Spell-checking and language dictionaries
            BobLevine MVP & Adobe Community Professional

            You do not set the dictionary in your preferences. The dictionary is a

            character level attribute but can also be set as part of a paragraph style.

            • 3. Re:  Spell-checking and language dictionaries
              Peter Spier Most Valuable Participant (Moderator)

              This is a common misconception, especially for new users. The dictionary choice inthe preferences is only choosing which dictionary to use among any that might be installed for each language, but does not assign any language attribute. The actual language of the text is assigned at the character level, which allows you to have the default set to ne language, but tag forein owrds with the correct language to use for them for spell check and hyphenation. There is a Language filed in the Character panel, the Control panel in text mode, and in your paragraphs style defintion dialog.

              • 4. Re:  Spell-checking and language dictionaries
                posterns Level 1

                I'm having a similar problem. I have a document that was originally created in IDCS6. Whenever I try to spell check it, it thinks I'm using Norwegian. If I try to change the Dictionary in the SpellCheck dialog box to English it just keeps reverting back to Norwegian and thus thinks that every English word is mispelled. How do I get this to recognize English.

                • 5. Re:  Spell-checking and language dictionaries
                  Peter Spier Most Valuable Participant (Moderator)

                  You need to change the language assigned to the text. If none of it should be Norwegian you can use Find/Change to search for the Norwegian language assignment and change it to English in the find format and change format sections, respectively.

                  • 6. Re:  Spell-checking and language dictionaries
                    posterns Level 1

                    Thanks Peter. That worked. Any idea why this might have happened?

                    • 7. Re:  Spell-checking and language dictionaries
                      Peter Spier Most Valuable Participant (Moderator)

                      Somebody set the default language to Norwegian by choosing it with no text selected.