4 Replies Latest reply on Sep 11, 2013 4:41 AM by Ness66

    I can't install the latest version, 11.8, of Flash Player

    Ness66

      My system is Mac OSX 10.6.8 and I have tried to install the latest version of Flash Player, 11.8. I follow all the steps but when  it is 95% installed it freezes and doesn't complete the installation. Since trying that I now have "BLOCKED PLUG-IN" showing up if I try to watch a video. My Safari system version is 5.1.9. Please help me, I'm not too savy on the computer.