4 Replies Latest reply on Sep 16, 2013 8:40 AM by sinious

    Debugging Air for Android in Flash Pro CC

    NatMax Level 1

      I have been using Flash to devlop Apps for Andoid and iOS since the beggining.

       

      I have been successful in debugging Flash CS6 and Flash Pro CC using my older HTC EVO running android 2.3.

       

      But have not been able to debug to the newer Samsung S4 with Android 4.2.

       

      Flash Pro CC does recognize the device and I have enabled debugging on device and I have valid ceritificate and entered the password.

       

      Debugging also fails on my Asus Transformer running Android 4.0+

       

      I have called Adobe support and they said they do not support using Adobe Flash to devlope Applications.

       

      Can Flash Pro CC debug Android 4+?

       

      Thank you

        • 1. Re: Debugging Air for Android in Flash Pro CC
          sinious Most Valuable Participant

          What exactly happens when you try to debug?

           

          When you run 'adb devices' on a command line you see your devices listed there correct?

           

          One thing that helps is to use the generic Google USB driver or at least have it handy. Download the Android SDK and it's in the SDK Manager. Here's where you'd find it (AndroidSDK\SDK Manager.exe):

           

          sdkmanager.JPG

           

          Note the selected "Google USB Driver" in the "Extras" rolldown. Grab it.

           

          Often when a device is too new or just can't connect, that driver will find it. Also keep that SDK up to the latest version and check the adb that comes with it to make sure it sees your device:

           

          devices.jpg

           

          If Flash can't see it, there was one old trick of copying over the updated Android SDK's adb over to Flash. I believe you copied over adb.exe, AdbWinApi.dll, AdbWinUsbApi.dll (and at the time aapt.exe) and overwrote your copy in your FLASH\AIR\lib\android\bin folder, then suddenly flash could find the devices.

          1 person found this helpful
          • 2. Re: Debugging Air for Android in Flash Pro CC
            NatMax Level 1

            Hello Sinious,

             

            I read and reviewed your excellent suggestes. Thank you for such a detailed response.

             

            While I have not used Android SDK alone, I did, previously install to get FLash Pro CS6 to see this handset, Samsung s4 Android 4.2.2. It did not work.

             

            WIth your advice I went to update it and it had gotten corrupted (missing files would not allow update to process) So I uninstalled and reinstalled from scratch.

             

            I checked my Flash Pro CC and it does see the device and allows me to select it from "Air for Andsroid Settings" dialog box, on the "Deployment" tab, under the "After Publishing" inside the Serial Number list-- with my device Box Checked.

             

            I publish, before I even try to debug and I get stuck in a continuous Publishing dialog.

             

            With your suggestions and new A SDK isntalled, my phone for the first time, popped up a dialog asking for permission to allow my computer to access debug!

             

            I thought it would be done.

            Restarted Flash Pro CC, which still recognized device and got stuck Publishing.

             

            I tried to cancel and Flash crashed out.

            I am restarting computer and phone.

            I will report back after restart.

             

            Thank you again for all of your efforts!

            • 3. Re: Debugging Air for Android in Flash Pro CC
              NatMax Level 1

              Greetings Sinious,

               

              After restart, I can see device in Flash Pro CC and I can set it to publish.

               

              It completes export but fails to complete copy and instal of file on Android device.

               

              I can manually copy file over and manually install, but since no automatic process works, I still can not debug.

               

              How do you suggest I instal the generic Android driver from ASDK?

               

              I have tried deleting the device driver in device manager, but as soon as I scan it reinstalls exisiting driver.

               

              You suggested I copy andf replace 3 files in Flash Pro for ADB, but I could not locate where they are in the SDK folder.

               

              All of your suggestions and ideas are most totally appreciated.

               

              Thank you again for you help!

              • 4. Re: Debugging Air for Android in Flash Pro CC
                sinious Most Valuable Participant

                Hmm, sounds like you're having a device permission issue.

                 

                Are you using the device in MTP transfer mode? That is the default and what should be used.

                 

                I don't have a SGS4 on me now (gf has it) and I've used it to test before so I do know it works, however I myself only have SGS3. I can't diagnose it too well at the moment.

                 

                As for basic pointers, I'd try things like this:

                 

                Easy:

                - Delete the app on the device after each test (to assure overwriting isn't some kind of issue)

                - (I forgot where but) check to see if you have apps defaultly installing to the SD card and disable that. Write to the phones internal storage to remove any SD card complications.

                 

                Hard:

                - Install the sync software if you haven't already

                - Reinstall the SGS4 drivers (sometimes reinstalling a few times does work, oddly)

                - Try the Google driver. (Uninstall any SGS4 drivers/sync software completely and make sure the device is disconnected. Afterwards connect the device and let it run through the self install process. After, locate the device in device manager. Open the properties of the device, click the Driver tab and Update Driver button. Navigate to the Google USB driver folder and select it (AndroidSDK\sdk\extras\google\usb_driver)).

                1 person found this helpful