21 Replies Latest reply on Jun 11, 2008 10:33 PM by Peter Grainge

    hey - sorry for working you guys today  : 0

    zjillian
      I'm getting this error when trying to publish - I was wondering if anyone recognized it?

      Thanks in advance,

      Jill
        • 1. Re: hey - sorry for working you guys today  : 0
          Captiv8r Adobe Community Professional & MVP
          Hi Jill

          I think we will need more information. For example, which version of RoboHelp? What RoboFlavor? (RoboHelp for Word or RoboHelp HTML) How exactly are you trying to publish? Is this WebHelp or FlashHelp or is it WebHelp Pro or FlashHelp Pro?

          Cheers... Rick
          • 2. Re: hey - sorry for working you guys today  : 0
            zjillian Level 1
            Good Morning Rick,

            The details:
            RoboHelp 7 HTML
            WebHelp Pro
            I publish by generating and on then hit next to the next screen where the server info is and then select Finish. Then it generates fine, but when I select publish afterwards it says "Connection failed, etc. Native Error - cannot accept uploading file"

            It seems to be a permissions problem but my sys adm said he gave me global permissions and it still didn't work. Is there any documentation on what the permissions need to be on the server?

            Thank you!

            Jill
            • 3. Re: hey - sorry for working you guys today  : 0
              zjillian Level 1
              More info - the sys adm says there is no URL it's publish by IP address only - is that an issue?
              • 4. Re: hey - sorry for working you guys today  : 0
                RoboColum(n) Level 5
                Hi Jill. This link contains details of the permissions required for RoboHelp Server 6. In RoboHelp Server 7 the setting of permssions is more automated but I think should be the same. If this doesn't work, try posting a message in the RoboEngine forum as there are more folks there than here who use RoboHelp Server.
                • 5. Re: hey - sorry for working you guys today  : 0
                  zjillian Level 1
                  Thanks, I did that still waiting for response - one last question - we have RoboHelp 7 and RoboHelp Server, do we need RoboEngine - I thought I read some where we didn't but I just want to start eliminating possibilities.

                  Thanks
                  • 6. Re: hey - sorry for working you guys today  : 0
                    zjillian Level 1
                    Thanks, I did that still waiting for response - one last question - we have RoboHelp 7 and RoboHelp Server, do we need RoboEngine - I thought I read some where we didn't but I just want to start eliminating possibilities.

                    Thanks
                    • 7. Re: hey - sorry for working you guys today  : 0
                      RoboColum(n) Level 5
                      No. RoboHelp Server 7 used to be called RoboEngine a few releases ago and the forum has not been renamed. BTW there are less RoboHelp Server users so a response may not be a quick as here. Did you check the permissions in that link?
                      • 8. Re: hey - sorry for working you guys today  : 0
                        hughbetcha
                        I am getting that error as well. The IT dept will reset the server which seems to fix the problem only temporarily. Hoping zjillian will update if the problem was fixed, and how.
                        • 9. Re: hey - sorry for working you guys today  : 0
                          MeWrite Level 1
                          I am trying to publish FlashHelp Pro and saw this issue. I am experiencing the same issue. I see in the RoboEngine forum someone from Australia is having this issue, but no one has replied in over a week. Has anyone resolved this problem? I can't believe so few users are using Pro versions.

                          IT says I have admin rights to the server, we are using Server 7 with RH7. RoboEngine is installed. I can access the Admin panel in a web browser. I can add users and see a couple reports, but not all because I cannot get the project to publish via the url. I have no problem publishing FlashHelp via the File System, but that is the only way it will publish.

                          I have several managers that would like to use the Reports feature and since that only runs using the Pro outputs, I need to resolve this issue before Go Live in 10 days.

                          Any help would be greatly apprecitated.

                          Cindy
                          • 10. Re: hey - sorry for working you guys today  : 0
                            Peter Grainge Adobe Community Professional
                            The only bit I can comment on is you refer to RoboEngine. For RH7 you must have RoboServer 7, Earlier versions will not work.

                            • 11. Re: hey - sorry for working you guys today  : 0
                              Peter Grainge Adobe Community Professional
                              Just reread. You talk of RoboServer and RoboEngine. Both?

                              • 12. Re: hey - sorry for working you guys today  : 0
                                MeWrite Level 1
                                No the article I read ( http://www.adobe.com/devnet/robohelp/articles/rhserver.html) states that you need roboengine. When I look at the server there is a folder called roboengine with a few files under that. Since this was a clean install of RoboServer 7 (read that to mean, this is a new server that never had any previous version of RoboServe on it) I assumed that the article was saying it needed RoboEngine on the RoboServer. Since this folder is there the RoboServer 7 install must have put this folder and those files there. Maybe RH just didn't rename said folder/files.

                                Cindy
                                • 13. Re: hey - sorry for working you guys today  : 0
                                  Peter Grainge Adobe Community Professional
                                  RoboEngine is the name for older versions of RoboServer.

                                  RH7 must have RoboServer 7.

                                  RoboServer is a complete product so if you have installed RoboEngine as well, that could the problem.

                                  John Daigle wrote that article so perhaps he can look in here when he gets a chance.

                                  • 14. Re: hey - sorry for working you guys today  : 0
                                    MeWrite Level 1
                                    Peter -- sorry, I think you are misunderstanding what I'm saying. We installed RoboServer 7 and that folder(RoboEngine) is on the server so it must have come from the install of RoboServer 7 because this server never had any previous version of RH on it.

                                    For example when I remote into the server I see a list of folders under RoboServer: Admin, Activation, BIN, Database, Script, Servers, etc...RoboEngine just happens to be one of the many folders in the program folder. So, either RoboEngine is part of the program or Adobe just never renamed that folder.

                                    Either way, I'm not too pressed about it, unless the files in this folder (3 in all: 2 dlls and a sif) are causing the conflict, but then again since this is part of the install, I assume that it's there for a reason.

                                    I was leaning toward a permission issue, but my IT guys like everyone else in this thread, keep telling me I have full admin rights. And I can publish via File System, but not URL. And there are no topics in RoboEngine addressing this (well 1, but no one responded to it). I think Adobe should rename it to RoboServer because I think most people don't know that RoboServer was called RoboEngine. But I digress.

                                    Cindy
                                    • 15. Re: hey - sorry for working you guys today  : 0
                                      Peter Grainge Adobe Community Professional
                                      When I read your post again after replying I saw that but decided to let you confirm beyond doubt. With that resolved, hopefully someone with RoboServer knowledge can take over.

                                      • 16. Re: hey - sorry for working you guys today  : 0
                                        Kevin Elmore
                                        quote:

                                        Originally posted by: MeWriteI can't believe so few users are using Pro versions.

                                        ...

                                        I have several managers that would like to use the Reports feature and since that only runs using the Pro outputs, I need to resolve this issue before Go Live in 10 days.



                                        I have a little to add to that. Our company was one of the users of RoboEngine. When we upgraded to RoboHelp 7, we declined on getting the server.

                                        And I'm so happy now.

                                        Perhaps it was just buggy, obsolete software. Maybe it was a bad install. Maybe the IIS server just needed a defrag and a hug. I don't know what the reason, but RoboEngine caused us headaches. The server would crash often, and the Search function didn't work over 90% of the time. I asked some questions in the RoboEngine forum, but I learned that most RoboHelp users don't even use the server software. That clenched it for me.

                                        Maybe Server 7 is far, far better than what RoboEngine had. I wouldn't know, because the server software left such a bitter taste in our mouths that we could not justify upgrading the software. We let it drop off completely, and now our server is healthy. Search works very well now.

                                        We did give up the reporting, though. We never used it, but the option is nice. I saw that another poster (one that I respect) uses Zoom Search. My research turned up some good things about this software. The downside seems to be that it requires a bit more patching to make it work with RoboHelp. I couldn't tell you how much of a detriment that would be, as I don't have it yet.

                                        Of course, that's not what you want to hear with 9 days to go.

                                        Kevin
                                        • 17. Re: hey - sorry for working you guys today  : 0
                                          Peter Grainge Adobe Community Professional
                                          There are instructions for ZoomSearch on my site.

                                          • 18. Re: hey - sorry for working you guys today  : 0
                                            MeWrite Level 1
                                            Kevin -- nope not what I was hoping to hear at all. Zoom Search may be an option, but not for us. If I go back and say the RoboServer has issues, there's gonna be a whole can of worms opened that I won't be able to put back. Still researching the problem and hoping for find an answer quickly. Will let you know if I find one or if I have other issues.
                                            • 19. Re: hey - sorry for working you guys today  : 0
                                              Kevin Elmore Level 1
                                              Well, hopefully RoboServer 7 will completely exceed my expectations, and you will have very little trouble. I hope that's true and wish you luck.

                                              I'll stop hijacking this thread now.

                                              Kevin
                                              • 20. Re: hey - sorry for working you guys today  : 0
                                                JaredHess Level 1
                                                quote:

                                                Originally posted by: Peter Grainge
                                                RoboEngine is the name for older versions of RoboServer.
                                                RH7 must have RoboServer 7.



                                                Just wanted to add a tidbit. For it to function with the reports and tracking info, this is correct. But if you just need to display topics, it seems to work fine. We run our old RoboEngine 5 with RH 7 on an internal web server to allow SMEs to review topics created.
                                                • 21. Re: hey - sorry for working you guys today  : 0
                                                  Peter Grainge Adobe Community Professional
                                                  Jared

                                                  Thanks but not understanding the point of publishing to RoboEngine if you only want topics. WebHelp (rather than WebhHelp Pro) would do that.