4 Replies Latest reply on Sep 20, 2013 6:07 AM by MarionJD

    cpEIGetValue error

    MarionJD Level 1

      I have a large number of files with a button that launches a script.  Recently, I had to change all of them because window.open no longer worked.  My script now looks like this:

       

      //<script type="text/javascript">

      function launchwin() {

      var SiteName="www.[DIRECTORY]";

      var TipName="01_Creating_a_Letter/01_Creating_a_Letter";

      document.location="http://"+SiteName+"/"+TipName+".htm";

      }

      //-->

      //]]>

       

      I'm not showing the directory on a public forum, but the link works if I patch it together manually, and the script works perfectly in other RoboHelp files.

       

      In this project, however, it brings up an error message "Unable to set property 'cpEISetValue' of undefined or null reference."  Code 0

       

      The error message also gives the URL for the link, which works correctly.

       

      If I click "No" to the message about continuing to run scripts, it launches the link.  If I click yes, I'm stuck.

       

      I've tried the script in several files in the project, and the same thing happens each time.

       

      Has anyone seen this?  Any ideas?

       

      It's a real problem for me - I'm going on a 3-week vacation this weekend, and the client wants the files quickly.

       

      Thanks for any help!

        • 1. Re: cpEIGetValue error
          Willam van Weelden Adobe Community Professional & MVP

          Where does the cpElGetValue come in? It looks like an Adobe Captivate variable to me, is that correct?

           

          Greet,

           

          Willam

          • 2. Re: cpEIGetValue error
            MarionJD Level 1

            Thanks for the response, Willam,

             

            It's not anywhere that I can find - not in the Robohelp file, not a Captivate variable, and not in either the .htm or .js files.

             

            It seems to have to do with points scored in Captivate.

             

            The reason I look for it in RoboHelp is that it happens when I click the button that launches the above script.  If I launch the Captivate .htm/.swf file link it works fine.

            • 3. Re: cpEIGetValue error
              Willam van Weelden Adobe Community Professional & MVP

              This sounds like a CP issue to me. It is not RoboHelp related in any case as it's just a JavaScript opening a popup window. But is seems Captivate fails to assign the variable to the popup.

               

              Try the following: Create an HTML file manually. Then add the JavaScript to that and try to open the file. You should get the same error. If so, it is certainly a CP error.

               

              I would suggest you also post on the Captivate forum.

               

              Greet,

               

              Willam

              • 4. Re: cpEIGetValue error
                MarionJD Level 1

                Thanks, Willam,

                 

                 

                 

                I have also posted on the Captivate forum.  Your suggestion of doing a

                manual html file is a good one - I'll try that.

                 

                 

                 

                The thing is, I've done hundreds of these and never had a problem.  It

                doesn't make sense that for this particular application it wouldn't work.

                 

                 

                 

                Fortunately, it's no longer urgent.  While the error message shows up in the

                RoboHelp preview, there is no problem when the project is published for the

                client (after much clearing of caches, etc.)  So I can figure it out at my

                leisure.

                 

                 

                 

                One possibility is that I had added a Google Analytics script to these files

                in RoboHelp, and that may be related.