4 Replies Latest reply on Jan 5, 2008 9:52 AM by kglad

    AS Class doesn't agree with MovieLoader

    Akai-to
      I've never posted here before, so if I miss something vital in this that most people post when requesting help, feel free to mention.

      Basically, I have one movie (the 'mini-game') which uses two different classes, "Eye.as" and "Target.as". I then have another movie (the 'hub') which loads the first one, the mini-game, via a MovieClipLoader. When I run the mini-game on its own, all is well and good. However, when I run the mini-game through the hub, the Target class just may as well not exist. Constructor, methods, everything, all gone. But, the Eye class works perfectly fine and as it should.

      Both classes extend MovieClip and are on the stage within other class-less MovieClips, not through code placement, but design in the WYSIWYG editor (Flash 8 Pro). The mini-game has a beginning frame with nothing but "stop();", and on the hub's MovieClipLoader's onLoadComplete event, the mini-game is sent to its initialization frame, which then sends it to the "instructions" portion (just a bunch of text and some graphics for the player). On which, the player may click a button and be moved onto the actual 'game' portion of the mini-game, which is where the instances of both Eye and Target exist.

      Has anyone else run into this before? I've tried having the Target on the stage at the start, just like the Eye, attaching it, or duplicating the targets from one already on the stage. Nothing seems to have any affect on the problem, and the problem only arises when run through the hub.

      Any help, comments, criticism, flames or anything else is welcome. I've hit a completely perplexing brick wall on this one. Thanks in advance for anything anyone can offer.