2 Replies Latest reply on Oct 3, 2013 11:24 AM by Crone2011

    Topics in TOC are not being published in Word output

    Crone2011

      Windows 7

      RoboHelp 9.0.2.271

      Word 2010

       

      I am having an on again/off again problem with RH not publishing all topics.

       

      The topics are in the RH TOC and when I double-click them while in RH, they open for editing.

       

      However, when I publish these same topics, they are not in the Word document--although they are in the web help.

       

      Previous fixes include rebuilding the TOC (groan) or finding that rogue piece of code that causes topics not to print in Word or web help.

       

      Question 1:  Does anyone know why this is happening?

       

      Question 2:  Short of manually comparing RH TOCs against Word and web help (for 13 books), does anyone have any ideas on how to ensure all topics are included in the output?

       

      Thanks in advance for any help.

       

      Mary

        • 1. Re: Topics in TOC are not being published in Word output
          Peter Grainge Adobe Community Professional (Moderator)

          There's a common misconception that what is in your TOC gets published.

           

          The TOC is used the first time you generate a printed document. Thereafter, there is no update for good reason, you may want different topics. To update to what is in the TOC you need to click the Left arrow to clear everything from the right pane, then click the right arrow to put the new version of the TOC across to the right.

           

          If you look at the current version of the TOC you will see some books on the left are not highlighted. That indicates there are topics in that book that are not on the right.

           

          See Printed Documentation on my site.

           


          See www.grainge.org for RoboHelp and Authoring tips

           

           

          @petergrainge

          • 2. Re: Topics in TOC are not being published in Word output
            Crone2011 Level 1

            Hi Peter,

             

            My original try at fixing the problem was exactly what you suggested. Sadly it didn’t work.

             

            What worked THIS time was to re-add the topic to the TOC using the Topic List. I don’t know why that worked.

             

            I  have this problem from time to time. Once it was a piece of HTML code that when removed allowed the rest of the document to print as it should.

             

            I can’t remember the other fix. I’m going to start writing these down.

             

            Regards,

            Mary