10 Replies Latest reply: Oct 6, 2013 12:59 PM by squawk ident RSS

    Greyed out icon on iPad

    squawk ident Community Member

      The .ipa file for the app has been loaded into iTunes - and when synched with the ipad it turns gray after completely downloading.  When the greyed out icon is tapped it shows "installing".  The same indication remains on iTunes.  The app was built using version 27.  The ipad has iOS 7. Has this anything to do with the version I am using? 

        • 1. Re: Greyed out icon on iPad
          squawk ident Community Member

          Can somebody please help me out here?  I've been trying to get this into iTunes for the last 3 days....I am stumped as to what to do to get this to work.  Thanks.

          • 2. Re: Greyed out icon on iPad
            Neil Enns - Adobe Adobe Employee

            Are you sure your device is correctly added to the mobileprovision file you used when building the application?

             

            Neil

            • 3. Re: Greyed out icon on iPad
              squawk ident Community Member

              Because this is a new version of an app already selling in the App

              Store, I am using the same mobileprovision file as I used the first time

              - as I want this app to replace the existing one already published on

              iTunes.  The documentation seems to indicate that for a new version,

              keeping the same App ID and distribution certificates the same is

              required for this purpose.  I am uncertain as to whether this pertains

              to the mobileprovision  certificates.  I have uninstalled InDesign on

              the Mac as well as the DPS app builder.  Everything has been reinstalled

              (using CC) and it is giving the exact same results. the .ipa file is

              downloaded to the desktop, and dragged into iTunes where it looks like a

              normal app.  When I synch it with the iPad it downloads properly and

              then darkens and will not open.

              • 4. Re: Greyed out icon on iPad
                squawk ident Community Member

                ..and yes, the UDID is properly noted and installed.  The only other thing I'm wondering about is that when I successfully uploaded the app to iTunes, it had me in the US (and I'm from Canada).  When I later tried to download my own app from the app store, it said I was in the wrong country - and I had to physically change the info.  So how on earth did it upload to the US store?  Can't figure that out - and perhaps that would solve my problem.  Every once in a while the Mac shows "Errior #1009" but not consistently. 

                • 5. Re: Greyed out icon on iPad
                  Nathan Marroquin Adobe Employee

                  Have you recreated the developer mobileprovision file as well as the p12 file, rebuilt with them and tried to install? Another user's problem was resolved that way.

                  http://forums.adobe.com/message/5634369#5634369

                  • 6. Re: Greyed out icon on iPad
                    squawk ident Community Member

                    Not yet because I don't want to affect the ability of previous purchasers to download the new version for free.  I understood that those certs had to remain the same as for the original app...but at this point I am so frustrated, I am probably missing something obvious in this process....

                     

                    Sent from my iPad

                    • 7. Re: Greyed out icon on iPad
                      Nathan Marroquin Adobe Employee

                      Are you attempting to install a distribution or developer signed application? You can only install the developer-signed application. The distribution signed application is not intended to be installed in this manner. Updating the developer certificates should not invalidate the application that customers get from the App Store.

                      • 8. Re: Greyed out icon on iPad
                        squawk ident Community Member

                        Ok thanks.  Needed confirmation of that. 

                         

                        Sent from my iPad

                        • 9. Re: Greyed out icon on iPad
                          Lisa Shugaar Community Member

                          This is the same problem I'm having with loading my dev ipa to my iPad via iTunes. It's v27, and I have the latest version of iTunes. The icon is grayed out and then goes into an endless loop of "Installing." I've tried this on both test devices linked to my apple dev account, one running ios 6 and the other 7.

                          Doesn't work on either one.

                          • 10. Re: Greyed out icon on iPad
                            squawk ident Community Member

                            I finally got it to work.  Mine is a new version of an existing app. I had made the mistake of removing the original app from iTunes.  I reinstalled the original .ipa file for the app already approved and uploaded this to the ipad.  Then, I removed that ipa file into trash and installed the .ipa file for the new bersion.  When I dragged it into ITunes the wonderful query came up 'this is a newer version of the app, do you want to install'?  Yes!!  It then gives you the option of 'update'. That should take care of the problem. 

                             

                            Sent from my iPhone