3 Replies Latest reply on Oct 10, 2013 12:17 PM by Willam van Weelden

    Converted from RH9 to RH10, CSH works for only a few screens

    lyddion

      I have a Parent project with mulitple child projects. Everything worked fine in RH9 with file mapping and CSH.  I converted my RH9 projects individually by opening them in RH10. For each project, I saw the following message and chose to upgrade:

       

      RH1.PNG

      I then just let RH10 'do it's thing' and got a message that the project was successfully upgraded:

      RH2.PNG

      For each project, I noticed that when I went to check my Map File, some Map ID's had topics assigned, while others seemed to have lost their assignment during the conversion (example below):

      RH3.PNG

      I noticed that if I exited RH10, then went back in, they system found all the 'lost' Topic assignments automatically:

      RH4.PNG

       

      I figured everything was fine with the Map ID's and assignments and then just generated every child project (and the parent project) in RH10.  Now I'm spot testing some of the help topics in our program and am finding that pressing <F1> to access CSH pages is hit and miss. Some topics load correctly, while others search and find nothing, then proceed to display the default Help project (in my case, the entire Help menu instead of the specific topic page).

       

      Not sure what broke between RH9 and RH10, because in most cases, all I did was upgarde the project without additional changes. I can't seem to pinpoint what is causing some pages to display and others not to associate the mapping and display the correct page, other than the original conversion issue I noted above.

       

      I've also checked the <projectName>.ali files and all the Map ID's and Topics seem to be in place in the file.

       

      Any ideas as to what I can check next?

        • 1. Re: Converted from RH9 to RH10, CSH works for only a few screens
          Willam van Weelden Adobe Community Professional & MVP
          • Try removing the CPD and reopening the project.
          • Are your map files filled correctly?
          • After that, go to the SSL settings and make sure you have all the map files selected for use in the output.

           

          If this fails, get a backup of the RH9 project. Then copy the .ali and map files into the RH10 project. Trash the CPD and open the RH10 project. That will give you the exact content of the RH9 project in RH10.

           

          Greet,

           

          Willam

          • 2. Re: Converted from RH9 to RH10, CSH works for only a few screens
            lyddion Level 1

            Willam,

             

            Removing the CPD file and reopening worked. I've also checked my SSL settings and those are fine too. So my Map Files look to be correct, but I'm still having issues with the CSH. I don't know if it's browser compatibility issues for certain pages in my projects, or the way RH10 has converted/generated them.

             

            When I tried using my RH9 generated content in our software,  every single page is mapped and works correctly as CSH. When I replace it  with RH10 content, about half the F1 help doesn't work.

             

            I'm at the point now where I'm considering going back to RH9 because RH10 is giving me nothing but problems (Chrome compatibility issues, weird .css requirements, etc.)

            • 3. Re: Converted from RH9 to RH10, CSH works for only a few screens
              Willam van Weelden Adobe Community Professional & MVP

              Do the map id’s contain changes?

               

               

               

              Can you use a diff tool (there’s a compare function in Notepad++) to verify that both the .ali and the map files are exactly the same? Also, try removing the existing output and then pushing the new output to the server. That way you won’t have any artefacts left accidentally.

               

               

               

              Greet,

               

               

               

              Willam