3 Replies Latest reply on Oct 7, 2013 4:57 PM by Mike M

    Can't install new flash player on Mac 10.5.8

    NadiasAdobe

      I have a MacBook version 10.5.8 and recently I have discovered I cannot watch videos or do anything that requires Flash Player because the version I have is out of date. However, when I try to download the new version, it tells me I cannot install it because the most recent version is only for Mac 10.6-10.9.

       

      I cannot purchase a new computer right now but I need to use Flash Player! Is there another version of Flash I can install that will work on Mac 10.5.8 and allow me to watch videos, etc.? Thank you for your help.