1 Reply Latest reply on Oct 10, 2013 11:58 AM by Mike M

    I have tried many things including uninstalling flash player but it still won't work

    herms_ra

      Im on a mac using OS X version 10.8.5. I've installed flash player countless times but when i go on youtube or any other site that requires flash, it tells me i need the latest version??