9 Replies Latest reply on Nov 6, 2013 2:48 AM by Peter Grainge

    Robohelp 10 crashes

    hara1121 Level 1

      Robohelp 10 crashes (runtime error - Visual C++ - runtime library) when I select printed documentaion.  Macros are enabled in Word.  Anyone have similar problems?

        • 1. Re: Robohelp 10 crashes
          Willam van Weelden Adobe Community Professional & MVP

          Which version of Word are you using? What are your generation settings?

           

          Greet,

           

          Willam

          • 2. Re: Robohelp 10 crashes
            Peter Grainge Adobe Community Professional

            Here's one thread that may help.

             

            http://forums.adobe.com/message/4062497#4062497

             

            Googling "runtime error - Visual C++ - runtime library" will get you 809,000 other links. It seems to be a Microsoft issue. I have just exchanged emails with someone who has a project I sent him and he is having this issue. Using the same project the printed document is produced on my machine.

             


            See www.grainge.org for RoboHelp and Authoring tips

             

             

            @petergrainge

            • 3. Re: Robohelp 10 crashes
              Peter Grainge Adobe Community Professional

              One thing to add, the other person is only having this problem with this one project. He has suggested could it be that my system is set to UK English whereas his is US English. I doubt that as we have regularly exchanged projects and not hit this problem. Also printing one of the samples would give similar issues as they are US based so I would expect issues there if language were the issue.

               

              Please try one of the sample projects and try to establish if the issue is general or project specific.

               

              Also try creating a new print layout in the project giving grief.

               


              See www.grainge.org for RoboHelp and Authoring tips

               

               

              @petergrainge

              • 4. Re: Robohelp 10 crashes
                hara1121 Level 1

                This is happening on a new IBM laptop with Windows 7 with MS Word 2010.  I had been using Robohelp 10 on another laptop - for almost a year now.

                 

                When I select "Printed Documentation" for the Salesbuilder sample project, I get the following and then RH 10 dies. Additionally, using Task Manager, I can see two winword processes left running after RH 10 dies. 

                 

                Untitled.jpg

                • 5. Re: Robohelp 10 crashes
                  Peter Grainge Adobe Community Professional

                  The person who had the problem with my project reinstalled Rh but that did not fix things. The project still through this error. Then he went back to the original I sent and it worked fine so the suspicion is somehow the project got corrupted.

                   

                  Try rebooting the machine and then opening the Employee Care project. Make sure you open the sample in your profile rather than the one in Program Files. Click Open on the RoboHelp Starter page and then click Samples in the ribbon on the left.

                   


                  See www.grainge.org for RoboHelp and Authoring tips

                   

                   

                  @petergrainge

                  • 6. Re: Robohelp 10 crashes
                    hara1121 Level 1

                    Fixed it!  The MS Word installation (its a new laptop), had several file block settings enabled in MS Word Trust Center. By unblocking them,  I was able to generate a Word doc of my HTML.

                     

                    fixed.jpg

                    • 7. Re: Robohelp 10 crashes
                      Peter Grainge Adobe Community Professional

                      Thank you for posting that back. It looks like it could be the cause of other reports so the information will be very useful.

                       

                      Nice detective work.

                       


                      See www.grainge.org for RoboHelp and Authoring tips

                       

                       

                      @petergrainge

                      • 8. Re: Robohelp 10 crashes
                        johndaigle Level 4

                        Hi, folks. I'm the mysterious "other person" who had similiar crash problems with Printed Docs. I did not participate in the thread till now because my testing environment is somewhat experimental and uses a different version of Rh.

                        But, based on hara1121's laudable sluething, I decided to check out my Word 2010 File Block Settings. (Show below)

                        FileBlockSettings.jpg

                        I unchecked the three boxes and rebooted. For me and the errant project, the crash is still occurring on that original project. And, as before, other projects generate Printed Docs as expected. So, I think my situation is caused by something different than hara1121. For practical purposes my solution was to take a copy of the original project and simply reopen it "fresh" in Rh. Everybody is happy now :-)

                        John

                        • 9. Re: Robohelp 10 crashes
                          Peter Grainge Adobe Community Professional

                          Hopefully there is now a simple solution to this problem.

                           

                          I worked with John as he had the problem with some projects and not others. After a few abortive attempts, I found this worked.

                           

                          1. Open Task Manager and make sure all instances of Word are closed OR reboot. This is to clear any running instances that the crash may have left.
                          2. Open the project and go to the SSL pod. Create a new Printed Doc layout. Doesn't matter what it contains. Use the default settings.
                          3. That should work. If it does, now try to generate the layout that was crashing. Should be OK.

                           

                          If anyone else tries this, please post your results, good or bad.

                           


                          See www.grainge.org for RoboHelp and Authoring tips

                           

                           

                          @petergrainge