4 Replies Latest reply on Oct 22, 2013 12:56 PM by Swati999

    InDesign Extension not showing when launch via 'Debug as' option

    Swati999 Level 1

      InDesign Extension not showing when launch via 'Debug as' option

       

       

      Hello everyone,

       

      I have been working on an InDesign Extension app for a couple of months now. I am a Creative Cloud member. I have FlashBuilder 4.6 + Extension Builder 2.1 (both licensed versions) and InDesign CS6 and CC installed on my machine. The application is targetted for InDesign CS 5.x, CS 6 and CC versions. Until now, I have been testing it via 'Run as' and 'Debug as' options from the FB; and timely, I did 'Export as' ZXP for internal releases.

      I am having two problems, not sure if they are related.

       

      1. When I try to do bundle manifest, it fails with following error: (at first, I thought this was an installation problem, but I made another simple test project and bundle manifest works on that one)

       

      Could not open the editor: An unexpected exception was thrown.

      Details:

      java.lang.NullPointerException

          at com.adobe.cside.ui.editors.pages.MainBundlePage.isPointProductSupported(Unknown Source)

          at com.adobe.cside.ui.editors.pages.MainBundlePage.createTargetAppSection(Unknown Source)

          at com.adobe.cside.ui.editors.pages.MainBundlePage.createFormContent(Unknown Source)

          at org.eclipse.ui.forms.editor.FormPage$1.run(FormPage.java:152)

          at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)

          at org.eclipse.ui.forms.editor.FormPage.createPartControl(FormPage.java:150)

          at org.eclipse.ui.forms.editor.FormEditor.pageChange(FormEditor.java:471)

          at com.adobe.cside.ui.editors.BundleManifestEditor.pageChange(Unknown Source)

          at org.eclipse.ui.part.MultiPageEditorPart.setActivePage(MultiPageEditorPart.java:1067)

          at org.eclipse.ui.forms.editor.FormEditor.setActivePage(FormEditor.java:603)

          at org.eclipse.ui.part.MultiPageEditorPart.createPartControl(MultiPageEditorPart.java:352)

          at org.eclipse.ui.internal.EditorReference.createPartHelper(EditorReference.java:670)

          at org.eclipse.ui.internal.EditorReference.createPart(EditorReference.java:465)

          at org.eclipse.ui.internal.WorkbenchPartReference.getPart(WorkbenchPartReference.java:595)

          at org.eclipse.ui.internal.EditorReference.getEditor(EditorReference.java:289)

          at org.eclipse.ui.internal.WorkbenchPage.busyOpenEditorBatched(WorkbenchPage.java:2945)

          at org.eclipse.ui.internal.WorkbenchPage.busyOpenEditor(WorkbenchPage.java:2850)

          at org.eclipse.ui.internal.WorkbenchPage.access$11(WorkbenchPage.java:2842)

          at org.eclipse.ui.internal.WorkbenchPage$10.run(WorkbenchPage.java:2793)

          at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)

          at org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPage.java:2789)

          at org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPage.java:2773)

          at org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPage.java:2756)

          at com.adobe.cside.ui.popup.actions.CSIDEBundleEditorAction.run(Unknown Source)

          at org.eclipse.ui.internal.PluginAction.runWithEvent(PluginAction.java:251)

          at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContributionI tem.java:584)

          at org.eclipse.jface.action.ActionContributionItem.access$2(ActionContributionItem.java:501)

          at org.eclipse.jface.action.ActionContributionItem$5.handleEvent(ActionContributionItem.java :411)

          at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)

          at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4128)

          at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1457)

          at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1480)

          at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1465)

          at org.eclipse.swt.widgets.Widget.notifyListeners(Widget.java:1270)

          at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3974)

          at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3613)

          at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2696)

          at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2660)

          at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2494)

          at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:674)

          at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)

          at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:667)

          at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)

          at com.adobe.flexbuilder.standalone.FlashBuilderApplication.start(FlashBuilderApplication.ja va:108)

          at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)

          at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLau ncher.java:110)

          at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.jav a:79)

          at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)

          at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)

          at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

          at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

          at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

          at java.lang.reflect.Method.invoke(Method.java:597)

          at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)

          at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)

          at org.eclipse.equinox.launcher.Main.run(Main.java:1410)

       

       

      Here is my manifest file:

       

      <?xml version="1.0" encoding="UTF-8"?>

       

      <ExtensionManifest Version="2.0" ExtensionBundleId="ConnectXPress"

          ExtensionBundleVersion="1.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

          <Author>

              <![CDATA[Swati Sisodia]]>

          </Author>

          <ExtensionList>

              <Extension Id="com.pubpress.CXP.extension1" Version="1.0" />

          </ExtensionList>

          <ExecutionEnvironment>

              <HostList>

                  <Host Name="IDSN" Version="7.0" />

                  <Host Name="AICY" Version="7.0" />

              </HostList>

              <LocaleList>

                  <Locale Code="All" />

              </LocaleList>

              <RequiredRuntimeList>

                  <RequiredRuntime Name="CSXS" Version="2.0" />

              </RequiredRuntimeList>

          </ExecutionEnvironment>

          <DispatchInfoList>

              <Extension Id="com.pubpress.CXP.extension1">

                  <DispatchInfo>

                      <Resources>

                          <SwfPath>./ConnectXPress.swf</SwfPath>

                      </Resources>

                      <Lifecycle>

                          <AutoVisible>true</AutoVisible>

                      </Lifecycle>

                      <UI>

                          <Type>Panel</Type>

                          <Menu>ConnectXPress</Menu>

                          <Geometry>

                              <Size>

                                  <Height>520</Height>

                                  <Width>350</Width>

                              </Size>

                          </Geometry>

                          <Icons>

                              <Icon Type="Normal">./icons/normal_icon.png</Icon>

                              <Icon Type="RollOver">./icons/rollover_icon.png</Icon>

                              <Icon Type="Disabled">./icons/disabled_icon.png</Icon>

                              <Icon Type="DarkNormal">./icons/dark_icon.png</Icon>

                              <Icon Type="DarkRollOver">./icons/dark_icon.png</Icon>

                          </Icons>

                      </UI>

                  </DispatchInfo>

              </Extension>

          </DispatchInfoList>

      </ExtensionManifest>

       

       

      2. My other problem is, I recently changed the project name and the application name in the Menu, and since I did that, my extension does not show when I perform 'Run as' or 'Debug as' from Flash Builder. Upon doing run as/ debug as, the code compiles and appears in 'bin-debug' folder, the app is fired but when I navigate to Windows>Extensions, my extension is not present there. Although when I export it as ZXP and install via Extension Manager CS 6 or CC, it does show my latest extension in Windows>Extensions with correct name.

       

      Any help is much appreciated. Please let me know if I should provide more information.

      Regards,

      Swati.

        • 1. Re: InDesign Extension not showing when launch via 'Debug as' option
          Hallgrimur Bjornsson Level 3

          Hi Swati,

           

          Thanks for the post.

           

          Did both these problem come up recently? Also, did both of them come up at the same time?

           

          Best regards,

          Hallgrimur

          --

          Hallgrimur Th. Bjornsson | Product Manager - SET | Adobe | Tel: +44 (0) 1314582787

          • 2. Re: InDesign Extension not showing when launch via 'Debug as' option
            Swati999 Level 1

            Hello Hallgrimur,

             

            Thanks for a quick reply. No, both the problems did not occur at the same time.

            Initially, I had Flash Builder 4.5 and Extension Builder 2.0 ( both trial versions ) installed, that's where I created the project, set target applications to be InDesign and InCopy and set the Flex Compiler to 3.4 (it is my understanding that to target CS 5.x applications, Flex Compiler version has to be 3.4 ...it will be great if you could confirm that too for me please.) At that time, I used to Bundle manifest all the time. Then, I switched to Flash Builder 4.6 and Extension Builder 2.1 licensed versions, imported my project there. This is exactly when I lost the bundle manifest facility.

            While the other problem of missing extension from Windows>Extensions of InDesign / InCopy via Debug/Run as option is rather recent, i.e., when I changed my project name ( in Flash Builder and in Menu node of manifest, which I accessed via a text editor ). I also changed the runnable application file name to match my new project name.

            • 3. Re: InDesign Extension not showing when launch via 'Debug as' option
              Swati999 Level 1

              One more piece of information, (thought may be relevant) I found following error in CS6ServiceManager_native.log file, located in /Users/<UserName>/Library/Application Support/Adobe/CS6ServiceManager/logs :

               

              2013-10-21 12:03:26 : ERROR vcfoundation::system::VCSysError: send() failed <32: Broken pipe>

              Trace: 0   CS6ServiceManager                   0x00004d95 _ZN12vcfoundation4base11VCExceptionC2EPNS_4data9IVCStringE + 71

              1   CS6ServiceManager                   0x00005766 _ZN12vcfoundation6system10VCSysErrorC1EPNS_4data9IVCStringEPKci + 36

              2   CS6ServiceManager                   0x00005e09 _ZN12vcfoundation6system10PosixError5ThrowEPNS_4data9IVCStringEi + 487

              3   CS6ServiceManager                   0x00005e9a _ZN12vcfoundation6system10PosixError5ThrowEPKci + 104

              4   CS6ServiceManager                   0x0003afd4 _ZN12vcfoundation6system10VCSysErrorD0Ev + 0

              5   CS6ServiceManager                   0x00041ab0 _ZN12vcfoundation3net3Bsd4SendEiPKvii + 64

              6   CS6ServiceManager                   0x000400f0 _ZN12vcfoundation2io12BSDNamedPipe5WriteEPKvm + 48

              7   CS6ServiceManager                   0x0003e2b9 _ZN12vcfoundation2io14BufferedWriter5FlushEv + 71

              8   CS6ServiceManager                   0x0003ec2a _ZN12vcfoundation5ncomm6NCHost6Worker13HandleRequestEv + 208

              9   CS6ServiceManager                   0x0003ecfd _ZN12vcfoundation5ncomm6NCHost6Worker3RunEv + 49

              10  CS6ServiceManager                   0x0003d779 _ZN12vcfoundation6thread14AbstractThread3RunEv + 53

              11  CS6ServiceManager                   0x00041683 _ZN12vcfoundation6thread6Thread10ThreadProcEPv + 17

              12  libsystem_c.dylib                   0x91a20ed9 _pthread_start + 335

              13  libsystem_c.dylib                   0x91a246de thread_start + 34

               

              2013-10-21 12:05:26 : ERROR not logged in

               

               

              I tried restarting Flash Builder, InDesign and my machine also a couple of times, still same problem.

              • 4. Re: InDesign Extension not showing when launch via 'Debug as' option
                Swati999 Level 1

                I solved both of my problems. And I thought I will post it for others.

                First problem, where the Bundle manifest failed from FlashBuilder, was solved by making a change in the manifest.xml (which lives in <projectName>/.staged-extension/CSXS). The change I made was <HostList> tag. Earlier it was (generated by FlashBuilder 4.5):

                        <HostList>

                            <Host Name="IDSN" Version="7.0" />

                            <Host Name="AICY" Version="7.0" />

                        </HostList>

                I changed it to:

                        <HostList>

                            <Host Name="IDSN" Version="[7.0,9.9]" />

                            <Host Name="AICY" Version="[7.0,9.9]" />

                        </HostList>

                I did a little bit of hit and trial and it appears that FlashBuilder 4.5 generated Host tag with Version attribute having only the minimum version targetted while FlashBuilder 4.6 requires all targetted versions listed in the Version attribute.

                 

                The second problem of Debug/Run as not installing the extension properly in InDesign, was fixed by performing the software update on FlashBuilder.

                Here's what led me to do that:

                I retraced my steps and realized last thing I did before the 'Debug as Adobe InDesign Extension' from within FlashBuilder broke on my machine was updating the InDesign CS6 to the latest available version, which probably ended up with different flash/flex versions of InDesign and FlashBuilder. So, performing a software update fixed the debug.