1 Reply Latest reply on Feb 12, 2008 1:36 PM by samaru

    Just learning can't install

    PunkJohnnyCash
      I am trying to learn to use flex. It seemed to install, and now when I go to start flex2 I get an error.

      I am running this on Vista home Premium. I ran a trial for 30 days, and I used the beta for a while. I just got flex builder 2 and uninstalled all the old stuff and now when I go to start up I get this:


      An error has occured. See the log file
      C:\Users\My Documents\Flex Builder 2\.metadata\.log.

      in that file I find

      !SESSION 2007-12-19 04:28:43.552 -----------------------------------------------
      eclipse.buildId=unknown
      java.version=1.4.2_12
      java.vendor=Sun Microsystems Inc.
      BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
      Command-line arguments: -os win32 -ws win32 -arch x86

      !ENTRY org.eclipse.update.configurator 2007-12-19 04:28:44.991
      !MESSAGE Cannot backup current configuration

      !ENTRY org.eclipse.update.configurator 2007-12-19 04:28:45.67
      !MESSAGE Could not rename configuration temp file

      !ENTRY org.eclipse.osgi 2007-12-19 04:28:46.314
      !MESSAGE Application error
      !STACK 1
      java.lang.UnsatisfiedLinkError: no swt-win32-3139 in java.library.path
      at java.lang.ClassLoader.loadLibrary(Unknown Source)
      at java.lang.Runtime.loadLibrary0(Unknown Source)
      at java.lang.System.loadLibrary(Unknown Source)
      at org.eclipse.swt.internal.Library.loadLibrary(Library.java:123)
      at org.eclipse.swt.internal.win32.OS.<clinit>(OS.java:18)
      at org.eclipse.swt.widgets.Display.<clinit>(Display.java:125)
      at org.eclipse.ui.internal.Workbench.createDisplay(Workbench.java:381)
      at org.eclipse.ui.PlatformUI.createDisplay(PlatformUI.java:155)
      at com.adobe.flexbuilder.standalone.FlexBuilderApplication.run(FlexBuilderApplication.java:4 5)
      at org.eclipse.core.internal.runtime.PlatformActivator$1.run(PlatformActivator.java:226)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:376)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:163)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      at java.lang.reflect.Method.invoke(Unknown Source)
      at org.eclipse.core.launcher.Main.invokeFramework(Main.java:334)
      at org.eclipse.core.launcher.Main.basicRun(Main.java:278)
      at org.eclipse.core.launcher.Main.run(Main.java:973)
      at org.eclipse.core.launcher.Main.main(Main.java:948)

      !ENTRY org.eclipse.osgi 2007-12-19 04:28:46.327
      !MESSAGE Bundle update@plugins/com.adobe.flexbuilder.debug.e32_2.0.155577/ [70] was not resolved.
      !SUBENTRY 1 org.eclipse.osgi 2007-12-19 04:28:46.327
      !MESSAGE Missing required bundle org.eclipse.debug.ui_[3.2.0,99.0.0).
      !SESSION 2007-12-19 04:35:34.11 ------------------------------------------------
      eclipse.buildId=unknown
      java.version=1.4.2_12
      java.vendor=Sun Microsystems Inc.
      BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
      Command-line arguments: -os win32 -ws win32 -arch x86

      !ENTRY org.eclipse.update.configurator 2007-12-19 04:35:35.27
      !MESSAGE Cannot backup current configuration

      !ENTRY org.eclipse.update.configurator 2007-12-19 04:35:35.90
      !MESSAGE Could not rename configuration temp file

      !ENTRY org.eclipse.osgi 2007-12-19 04:35:36.21
      !MESSAGE Application error
      !STACK 1
      java.lang.UnsatisfiedLinkError: no swt-win32-3139 in java.library.path
      at java.lang.ClassLoader.loadLibrary(Unknown Source)
      at java.lang.Runtime.loadLibrary0(Unknown Source)
      at java.lang.System.loadLibrary(Unknown Source)
      at org.eclipse.swt.internal.Library.loadLibrary(Library.java:123)
      at org.eclipse.swt.internal.win32.OS.<clinit>(OS.java:18)
      at org.eclipse.swt.widgets.Display.<clinit>(Display.java:125)
      at org.eclipse.ui.internal.Workbench.createDisplay(Workbench.java:381)
      at org.eclipse.ui.PlatformUI.createDisplay(PlatformUI.java:155)
      at com.adobe.flexbuilder.standalone.FlexBuilderApplication.run(FlexBuilderApplication.java:4 5)
      at org.eclipse.core.internal.runtime.PlatformActivator$1.run(PlatformActivator.java:226)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:376)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:163)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      at java.lang.reflect.Method.invoke(Unknown Source)
      at org.eclipse.core.launcher.Main.invokeFramework(Main.java:334)
      at org.eclipse.core.launcher.Main.basicRun(Main.java:278)
      at org.eclipse.core.launcher.Main.run(Main.java:973)
      at org.eclipse.core.launcher.Main.main(Main.java:948)

      !ENTRY org.eclipse.osgi 2007-12-19 04:35:36.37
      !MESSAGE Bundle update@plugins/com.adobe.flexbuilder.debug.e32_2.0.155577/ [70] was not resolved.
      !SUBENTRY 1 org.eclipse.osgi 2007-12-19 04:35:36.37
      !MESSAGE Missing required bundle org.eclipse.debug.ui_[3.2.0,99.0.0).
      !SESSION 2007-12-21 04:20:09.683 -----------------------------------------------
      eclipse.buildId=unknown
      java.version=1.4.2_12
      java.vendor=Sun Microsystems Inc.
      BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
      Command-line arguments: -os win32 -ws win32 -arch x86

      !ENTRY org.eclipse.update.configurator 2007-12-21 04:20:16.492
      !MESSAGE Cannot backup current configuration

      !ENTRY org.eclipse.update.configurator 2007-12-21 04:20:16.585
      !MESSAGE Could not rename configuration temp file

      !ENTRY org.eclipse.osgi 2007-12-21 04:20:18.820
      !MESSAGE Application error
      !STACK 1
      java.lang.UnsatisfiedLinkError: no swt-win32-3139 in java.library.path
      at java.lang.ClassLoader.loadLibrary(Unknown Source)
      at java.lang.Runtime.loadLibrary0(Unknown Source)
      at java.lang.System.loadLibrary(Unknown Source)
      at org.eclipse.swt.internal.Library.loadLibrary(Library.java:123)
      at org.eclipse.swt.internal.win32.OS.<clinit>(OS.java:18)
      at org.eclipse.swt.widgets.Display.<clinit>(Display.java:125)
      at org.eclipse.ui.internal.Workbench.createDisplay(Workbench.java:381)
      at org.eclipse.ui.PlatformUI.createDisplay(PlatformUI.java:155)
      at com.adobe.flexbuilder.standalone.FlexBuilderApplication.run(FlexBuilderApplication.java:4 5)
      at org.eclipse.core.internal.runtime.PlatformActivator$1.run(PlatformActivator.java:226)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:376)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:163)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      at java.lang.reflect.Method.invoke(Unknown Source)
      at org.eclipse.core.launcher.Main.invokeFramework(Main.java:334)
      at org.eclipse.core.launcher.Main.basicRun(Main.java:278)
      at org.eclipse.core.launcher.Main.run(Main.java:973)
      at org.eclipse.core.launcher.Main.main(Main.java:948)

      !ENTRY org.eclipse.osgi 2007-12-21 04:20:18.830
      !MESSAGE Bundle update@plugins/com.adobe.flexbuilder.debug.e32_2.0.155577/ [70] was not resolved.
      !SUBENTRY 1 org.eclipse.osgi 2007-12-21 04:20:18.831
      !MESSAGE Missing required bundle org.eclipse.debug.ui_[3.2.0,99.0.0).
      !SESSION 2007-12-21 04:23:38.353 -----------------------------------------------
      eclipse.buildId=unknown
      java.version=1.4.2_12
      java.vendor=Sun Microsystems Inc.
      BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
      Command-line arguments: -os win32 -ws win32 -arch x86

      !ENTRY org.eclipse.update.configurator 2007-12-21 04:23:39.615
      !MESSAGE Cannot backup current configuration

      !ENTRY org.eclipse.update.configurator 2007-12-21 04:23:39.674
      !MESSAGE Could not rename configuration temp file

      !ENTRY org.eclipse.osgi 2007-12-21 04:23:41.571
      !MESSAGE Application error
      !STACK 1
      java.lang.UnsatisfiedLinkError: no swt-win32-3139 in java.library.path
      at java.lang.ClassLoader.loadLibrary(Unknown Source)
      at java.lang.Runtime.loadLibrary0(Unknown Source)
      at java.lang.System.loadLibrary(Unknown Source)
      at org.eclipse.swt.internal.Library.loadLibrary(Library.java:123)
      at org.eclipse.swt.internal.win32.OS.<clinit>(OS.java:18)
      at org.eclipse.swt.widgets.Display.<clinit>(Display.java:125)
      at org.eclipse.ui.internal.Workbench.createDisplay(Workbench.java:381)
      at org.eclipse.ui.PlatformUI.createDisplay(PlatformUI.java:155)
      at com.adobe.flexbuilder.standalone.FlexBuilderApplication.run(FlexBuilderApplication.java:4 5)
      at org.eclipse.core.internal.runtime.PlatformActivator$1.run(PlatformActivator.java:226)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:376)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:163)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      at java.lang.reflect.Method.invoke(Unknown Source)
      at org.eclipse.core.launcher.Main.invokeFramework(Main.java:334)
      at org.eclipse.core.launcher.Main.basicRun(Main.java:278)
      at org.eclipse.core.launcher.Main.run(Main.java:973)
      at org.eclipse.core.launcher.Main.main(Main.java:948)

      !ENTRY org.eclipse.osgi 2007-12-21 04:23:41.582
      !MESSAGE Bundle update@plugins/com.adobe.flexbuilder.debug.e32_2.0.155577/ [70] was not resolved.
      !SUBENTRY 1 org.eclipse.osgi 2007-12-21 04:23:41.582
      !MESSAGE Missing required bundle org.eclipse.debug.ui_[3.2.0,99.0.0).
        • 1. Re: Just learning can't install
          samaru
          I had the same problem while starting Flex Builder 2. I have Windows Vista OS and sometimes I have to run certain applications for the first time as "Administrator" so I tried doing the same with Flex. Here's how -- go to Adobe Flex Builder 2 from your start menu and right click. Choose "Run as Administrator" and then it should run. Best of Luck!