1 Reply Latest reply: Oct 29, 2013 2:21 AM by PECourtejoie RSS

    CS5 compatibility with Mavericks

    LindaRKknapp

      I have Photoshop CS5 and would like to upgrade my MacMini to Apple's new operating system, Mavericks, but won't do it unless CS5 is compatible with Mavericks. Is it?