2 Replies Latest reply on Oct 30, 2013 3:43 PM by OlyWaGuy

    Non-Printable buttons showing up in wrong order when exported to interactive PDF!

    OlyWaGuy

      I am creating a generic customizable holiday gift certificate to post on our website for download. I am creating it using InDesign CS6. The idea is that the interactive PDF can be opened in Reader, one of six certificate graphics can be chosen (via radial buttons that hide/show graphics which have been converted to buttons), and various text fields can be filled in. Then the certificate can be printed and cropped. I have all the interactive elements working great, including the print button. The Interactive PDF looks like this:

      Waste_Free_Certificates_correct.jpg

      However, when printed, I would like ONLY the certificates and text feilds to print, and not the instructions, header, or certificate selection radial buttons, or full color background. The point of this is so that the user does not waste any ink. I would like it to print like this:

      Waste_Free_Certificates_printed.jpg

      At first I tried making individual objects nonprintable, but that also made them not show up upon export to interactive PDF. I then tried the same by putting them on a different layer and unchecking "print layer" (but checking "show layer"), but I ran into the same result. After searching the forums, I found out that the only way to make these items nonprintable, yet still visible in the interactive PDF, is to convert each object to a button, and then uncheck the "printable" box in the Buttons and Forms window. I did this, and everything now seems to work fine...

       

      Except that when exported, the buttons are exporting in the wrong stacking order, like this:

      Waste_Free_Certificates_wrong.jpg

      This colored background keeps on moving in front of everything else. Even if I put this on it's very own layer, beneath the layer with all the other graphics (converted to buttons) on it, it still shows up in front of all the other buttons. It is the same whether or not I check the Create Acrobat Layers box. What the heck am I doing wrong?