2 Replies Latest reply on Dec 21, 2007 12:45 AM by bluestix

    Flex 3 Incompatible with Cairngorm?

    bluestix
      I used the Data import tools to code generate a WSDL into an empty project.

      This worked and I was able to successfully make calls to the service.

      I then tried generating the same WSDL into a Flex 3 Project that uses the Cairngorm.swc that I had previously recompiled successfully from Flex 2.

      In the project that uses Cairngorm the generated code for the webservice fails to compile.

      First it has errors about multiname references for every class in mx.rpc.soap and mx.rpc.soap.wsdl

      After going through the BaseService component in the generated code and changing all of these references to their full path a whole new ridiculous set of build errors come up that cannot be resolved.

      For example:

      1046: Type was not found or was not a compile-time constant: WSDLOperation

      1046: Type was not found or was not a compile-time constant: Schema


      Those are just two of the many errors I got when trying different combinations of imports to get rid of the multiname reference errors.

      Unfortunately I never found the magic combination that would make it compile.

      I am not a huge fan of Cairngorm and would probably prefer to not use it given the choice but since the company I work for already did a year of development on their project, it would be a huge hassle to go through the entire project to remove all references to it.

      Any suggestions?


      BTW: There are also quite a few glaring bugs in my install of Flexbuilder 3 Beta 3.

      Import projects fails completely. The wizard goes through the first two steps and then the next button, it does nothing.

      Also in project properties the build path tab doesn't display. The modules tab doesn't display. And the project references tab only displays about half of the time and when it does display it doesn't work. Meaning that even if I reference another project I cannot use code from that project.

        • 1. Re: Flex 3 Incompatible with Cairngorm?
          Ivascu Cristian Level 1
          Hi,

          I have a few question to better understand the problem:

          What version of Cairngorm and Flex SDK are you using? Is Cairngorm rebuilt using the latest SDK? Also, considering the errors you mentioned further on I think there may be something wrong with the installation - do you have Flex Builder 2 and 3 installed on the same machine, or is the workspace inherited from an older version?

          As for the import project issue, what type of project did you use?

          Thanks,
          Cristian
          • 2. Re: Flex 3 Incompatible with Cairngorm?
            bluestix Level 1
            Hi

            Nevermind about the Cairngorm. I downloaded the latest source and used that instead of the swc. I didn't realize it before but the project was using an outdated version of the swc. Using the new sources the project compiled fine.

            As for Flexbuilder:

            Yea I have both 2 and 3 installed on the same machine.

            The workspace maybe the same. I didn't think about that before. I will create a new workspace and try recreating the project there.

            I was trying to import a flex project that previously lived in Flexbuilder 2. So far no luck.

            I had to create a new project that used the old code and I had to edit the build path when I created it because that was the only time I had the option. After that it no longer displayed.

            Either way I am able to workaround the issues so its not a huge problem but it is sort of inconvenient.

            Thanks for the quick response.

            You guys will be off soon. Hope you have a good holiday. Happy Saturnalia.