3 Replies Latest reply on Sep 26, 2014 3:39 AM by Peter Spier

    InDesign CS4 on Mavericks error

    dmgifford

      Running Mavericks on a new Macbook Air, and have an issue that's got me beat... 

       

      After installing CS4 Design Premium from the original CDs, all programs work fine except InDesign (which worked fine on the old Macbook Pro, on Lion).

       

      No problems at all with the installation, but when trying to open it I get the popular 'Licensing for this product has stopped working' error, with error code '5'.

       

      I followed Adobe's solution options advice, including an uninstall/reinstall, from here:

       

      http://helpx.adobe.com/x-productkb/global/error-licensing-stopped-mac-os.html

       

      However, one solution option I couldn't do - and I'm guessing this is the crucial one - was the one using the Licence Repair Tool.

       

      This wouldn't even launch, due to 'PowerPC applications no longer being supported' in the Mac OS, according to the error. I believe this has been the case for a while now in the later Mac OSs, although the tool is still available for download.

       

      I've also updated JRE, also to no avail.

       

      A Live Chat session with Adobe didn't help either, as they said CS4 is no longer supported via this route - but couldn't give me an alternative option for seeking a resolution, other than to look online (which I've spent a couple of days doing!)

       

      So I'm pretty sure I've exhausted all my options...

       

      I might have missed something though, so any thoughts or advice would be gratefullly received, thanks - especially on an alternative way to somehow get the Licence Repair Tool working with my OS; I think this might be the key.

        • 1. Re: InDesign CS4 on Mavericks error
          BobLevine MVP & Adobe Community Professional

          AFAIK, CS4 is unsupported under anything later than Lion. In short, you're

          pretty much on your own with Mavericks.

           

          Checking the FAQ, the only application earlier than CS6 that was tested on

          Mavericks was Photoshop. Others are not mentioned.

          • 2. Re: InDesign CS4 on Mavericks error
            hausmic

            Today i face the same problem as described by dmgifford. After SSD update i installed the CS4 Design Premium with Mavericks. The installation log for Indesign delivers 'Error 2' without any comment or hint.

            During installation i had to terminate the AIR module installation process, because the whole installation were stopped.

            Surprisingly other programs like PS, Ai and Bridge are running .... thats confusing and its no solution by Adobe to terminate support due to older versions!

             

            Maybe anybody has an idea to solve this problem ? Or Adobe delivers a new free Indesign version ?

            • 3. Re: InDesign CS4 on Mavericks error
              Peter Spier Most Valuable Participant (Moderator)

              This isn't Adobe's doing, it's Apple. Complain to them that they don't have backward compatibility for code that worked on previous versions of their OS.