2 Replies Latest reply on Nov 13, 2013 12:40 PM by Tracy2

    Downloading e books successfully.  I need help.

    Lynnnana Level 1

      I can get the downloads of most e-pubs, but I am having trouble getting some of them to download.  The Adobe Reader pops up and says the file is corrupted.  Then, the Adobe Digital Editions can't download a good book.  I must be doing something wrong. Can anyone help me fix this problem?  Thanks!

        • 1. Re: Downloading e books successfully.  I need help.
          sjpt Level 4

          I haven't seen that issue.  I have one general suggestion that helps in many cases and may help in yours.

           

          ~~~~~~~~~

          There are lots of bugs in ADE2.0 (and 2.0.1).  Try replacing ADE2.0 with the older but more reliable v1.7.2.

          (You can have them both installed at once if you like.)

          Version 1.7.2, it is a little difficult to find, available on Adobe site for Windows and for Mac.

          http://helpx.adobe.com/digital-editions/kb/cant-install-digital-editions.html

          The forum software is sometimes corrupting the link above.  There shouldn't be a blank in 'editio ns.html'.  The following redirects to the same page: http://tinyurl.com/diged172

           

           

          Some people have found ADE trying to upgrade automatically. 

          It appears (not 100% sure) that if you install ADE2.0 as a new install (not as an upgrade) that your 1.7.2 will continue to run.

          Probably best to say no if 2.0.x installation asks if you want to migrate your library.

          • 2. Re: Downloading e books successfully.  I need help.
            Tracy2

            I am having many problems with ADE 2.01. Downloading from the online library used to be simple with ADE 1.72 , but since I upgraded, nothing but problems. When downloading a book, sometimes it goes right, other times--most times--it downloads to my computer but ADE doesn't launch to accept the download. Instead, I have to launch it manually, then drag and drop the downloaded epub files from their containing folder on my computer. Then, they go in okay, but they don't have the familiar tag across the top rleft corner of the book image telling how long the file is usable. Right clicking on the file shows the info window, but the return early option is greyed out and can't be used.

            I uninstalled 2.01 and tried installing 1.72, but after great trouble trying to find a downloadable 1.72 version, I couldn't get it to authorize. Eventually, by switching from Firefox (my preferred browser) to IE and then downloading 2.01, I got it to authorize. Worked fine for several days, then started with the "can't connect with server" messages again. Total BS! ADE is garbage!