3 Replies Latest reply on Nov 14, 2013 4:23 AM by sjpt

    I cannot add library books to my kobo with digital editions anymore. How to fix this?

    catman24

      Ever since I got my kobo touch a year ago, I have not had any problems adding ebooks from my library to it. The last ebook I added to it successfully was in July 2013. A couple of days ago I tried to add a library book to it with Adobe Digital Editions 2.0, and the book on my kobo (which has the latest update installed to it) appeared to have a black cover. When I press on it, this error message comes up: "Opps! This document couldn't be opened. This document is protected by Adobe Digital Rights Management (DRM) and is not currently authorized for use with your Adobe ID. Please sign in with the authorized Adobe ID and try again." Trust me I have tried everything to get this thing to work, and it's driving me insane!!!

       

      I have tried all of the following with no luck:

       

      -I downloaded 3 books from my library and each of them had the same error message

      -The adobe ID on my kobo and my computer matches and are signed in

      -I have also downloaded Adobe digital editions 1.7.2 and tried the same whole process

      -I have factory reseted my kobo

       

      So how do I go about fixing this?

        • 1. Re: I cannot add library books to my kobo with digital editions anymore. How to fix this?
          sjpt Level 4

          One possibility, not at all sure it will help but worth a try.

           

          ~~~~~

          Sometimes ADE gets its registration/activation confused and in a semi-authorized state.

          Uninstalling and reinstalling does not help.

          Unfortunately, it often then gives misleading error messages about what is wrong.

          A common incorrect message informs you that the ID is already in use on another computer and cannot be reused.

          It is also possible that it is reporting that you are authorized but you are now only partly authorized.

           

          This can often be resolved by completely removing any authorization using ctrl-shift-D to the Library screen on ADE (cmd-shift-D if on Mac).

          Restart ADE, and then reauthorize with your (old) Adobe ID.

           

          In extreme cases on the mac, the following extra step has helped some people.  Navigate to /Users//Library/Application Support/Adobe/Digital Editions and drag the activation.dat file to the trash. If you are using 10.7, see Access hidden user library files | Mac OS 10.7 Lion. http://forums.adobe.com/thread/1265248?tstart=0

          • 2. Re: I cannot add library books to my kobo with digital editions anymore. How to fix this?
            Tracy2

            Huh. I tried the removing my authorization as you suggest and then couldn't re-authorize! Error message kept popping up telling me ADE couldn't connect with the server and to check that my computer was online. Had to uninstall ADE and re-install with a whole host of new problems already reported in anoth thread.

            • 3. Re: I cannot add library books to my kobo with digital editions anymore. How to fix this?
              sjpt Level 4

              Sorry about that.  ADE 2 is unfortunately a load of rubbish.

               

              @Tracy2: I see from your other thread that you even had problems with 1.7.2. so comment below probably wrong ....

               

              Why don't you start your own thread with details of all your issues.

              I see your frustration with this rubbish software,

              but mixing your issues into two three other people's threads makes things confusing ....

               

              ~~~~~~~~~

              There are lots of bugs in ADE2.0 (and 2.0.1).  Try replacing ADE2.0 with the older but more reliable v1.7.2.

              (You can have them both installed at once if you like.)

              Version 1.7.2, it is a little difficult to find, available on Adobe site for Windows and for Mac.

              http://helpx.adobe.com/digital-editions/kb/cant-install-digital-editions.html

              The forum software is sometimes corrupting the link above.  There shouldn't be a blank in 'editio ns.html'.  The following redirects to the same page: http://tinyurl.com/diged172

               

               

              Some people have found ADE trying to upgrade automatically. 

              It appears (not 100% sure) that if you install ADE2.0 as a new install (not as an upgrade) that your 1.7.2 will continue to run.

              Probably best to say no if 2.0.x installation asks if you want to migrate your library.