3 Replies Latest reply on Aug 6, 2006 2:49 AM by Newsgroup_User

    dw 8 with mysql connection - no tables

    rick111 Level 1
      This is how the connection is setup http://img469.imageshack.us/img469/1408/1dy1.jpg
      This proves I have tables http://img443.imageshack.us/img443/6436/2qp8.jpg

      Now I am a n00b to DW and MySQL but have had many years in the IT industry

      Any ideas?


      [I have looked at the suggested in http://www.adobe.com/cfusion/webforums/forum/messageview.cfm?catid=189&threadid=1174350&hi ghlight_key=y&keyword1=tables but as you can see, I don't have any 'copy to' folder http://img188.imageshack.us/img188/7338/3lh4.jpg
      Thanks
      Ryan
        • 1. Re: dw 8 with mysql connection - no tables
          Level 7
          rick111 wrote:
          > This is how the connection is setup
          > http://img469.imageshack.us/img469/1408/1dy1.jpg
          > This proves I have tables http://img443.imageshack.us/img443/6436/2qp8.jpg

          The problem is almost certainly caused by the hyphen in your database
          name. Hyphens are illegal characters in SQL identifiers, unless
          "quoted". The MySQL standard for quoting is to use backticks around
          identifiers that use illegal characters. phpMyAdmin does this by
          default, which is why you're seeing everying in phpMyAdmin.

          Dreamweaver now also does it by default, but there was a version (I
          forget which) that didn't do it. You need to apply the appropriate
          updater to your version of Dreamweaver. Then go to the Site menu, click
          Advanced, and select Remove Connection Scripts. Open a Recordset or
          other database connected dialog box to generate the new connection
          scripts, which should display the missing tables.

          --
          David Powers
          Adobe Community Expert
          Author, "Foundation PHP for Dreamweaver 8" (friends of ED)
          http://foundationphp.com/
          • 2. Re: dw 8 with mysql connection - no tables
            rick111 Level 1
            After following what you said word for word (removing the connection via site/advanced, rather than just deleting it from application tab and re-creating) it all now works as designed

            Thank you very much
            Ryan
            • 3. Re: dw 8 with mysql connection - no tables
              Level 7
              rick111 wrote:
              > After following what you said word for word (removing the connection via
              > site/advanced, rather than just deleting it from application tab and
              > re-creating) it all now works as designed

              Glad that worked for you. The option to remove the connection scripts is
              tucked away in a rather obscure place (probably because it's something
              you rarely ever need to do).

              --
              David Powers
              Adobe Community Expert
              Author, "Foundation PHP for Dreamweaver 8" (friends of ED)
              http://foundationphp.com/