1 Reply Latest reply: Nov 13, 2013 4:48 AM by vishu#13 RSS

    Trying to connect MS Access database to CF10 administrator

    theshusher

      Hello there. I'm just trying to set CF 10 administrator at home (Windows 8.1 Pro) so I can work on a few projects on my own machine but I can't get a data connection worked out.

       

      I've tried connecting an Access database (Office 2013, 32-bit) in the CF 10 administrator under the "Microsoft Access" driver as well as "ODBC socket" and I haven't been successful with either.

       

      Under Microsoft Access driver, I just key in the path to the database under "Database File" and leave Use Default User name checked. When I submit I get the error "Unable to update the NT registry. Variable DRIVERPATH is undefined." When I then try to verify the connection, I get the error, "The specified DSN contains an architecture mismatch between the Driver and Application." (I have tried saving the database backwards as a 2002-2003 .mdb file with the same results.)

       

      I've also tried setting up my database as an ODBC data source in Windows. In ODBC Data Source Administrator (32-bit) I set up a System DSN connecting through all available Access drivers successfully, but they do not appear in the "ODBC DSN" field under the ODBC Socket option in the CF 10 administrator.

       

      Anyone have any clue what I could do differently? Or I'm willing to try another local set up if another method is easier. Thank you.

        • 1. Re: Trying to connect MS Access database to CF10 administrator
          vishu#13 Community Member

          Hi

           

          Download the 32 bit Access Database Engine

           

          http://www.microsoft.com/download/en/details.aspx?id=13255

           

          NOTE : If Office is 32 bit then download the first file : AccessDatabaseEngine.exe

           

          Create a test database in access 2010 as test.accdb

           

          Add a Data Source in CF 10

           

          Say : access

          Driver : Microsoft Access

          Database file : C:\Users\test\Desktop\test.accdb

           

          Just fill in these 3 details, click Submit

           

          Ignore the message completely

           

          Unable to update the NT registry.

          Variable DRIVERPATH is undefined.

           

           

          Go to location : C:\Windows\SysWOW64 and run  odbcad32.exe as Run as Admin

           

          Click on System DSN and then click on Add. Scroll down a little bit and choose Microsoft Access Driver (*.mdb, *.accdb)

           

          Give the datasource name : access and click OK

           

          Now run the .cfm and test the behavior

           

          Thanks

          VJ