4 Replies Latest reply on Nov 20, 2013 11:59 PM by tribule

    double quotes/single quote problem in Coldfusion with back end as ORacle

    meensi Level 2

      Hi All,

      Here is my problem,

      I have a user defined function, which will give me the output as " table.column = <cfqueryparam cfsqltype = 'cf_sql_varchar' value = 'test'>;

      but when i pass this as my where clause in the query.

      I always get missing experssion (00936) error.

       

      When I ON the debug information in CF, I copied the query its running;

       

      any help would be highly appreciated.

       

      I have tried replacing this double quotes with single quotes using Rereplace and replace function;  tried preservesinglequotes(); all are returning the same error.. May be I'm missing something.

       

      THe below is the query formed; and its the one I get when I on the debug information (sql)

       

      SELECT *  FROM  SHOP_FINDINGS  WHERE   ROWNUM<=20 AND (OPER_NAME = <cfqueryparam cfsqltype='CF_SQL_VARCHAR' value='IN STOCK'> )

       

      I m using CF 9 and Apache server.