5 Replies Latest reply: Jan 15, 2014 7:26 AM by rasterdan RSS

    RH10 Project wont save topics in Design view.

    rasterdan Community Member

      I made a post a year ago where I solved problems in a project where we could not save topics in Design view.  We have to go to HTML view before a topic will save.  In the past we found that the problem was corrupted and or blank User Variables.  This project only has 1 variable now and when we upgraded from RH9 to RH10, our problem is back.  No other issues exist in this project ... so far ... that we can se as a result from the RH10 upgrade.

      Has anyone else had this problem and or have their solution?  We have other projects like this one that have no trouble at all.  This project was created about 8 years ago and has propagated through many versions of RH where our other projects have only been through 1 or 2 upgrades.  Maybe some legacy junk is messing this one up?

      Thanks,

      dv

        • 1. Re: RH10 Project wont save topics in Design view.
          Peter Grainge CommunityMVP

          Welcome back!

           

          I havent seen anyone else report this so nothing to offer. That sort of confirms your train of thought about the age of the project.

           

          Might be worth trying to delete the CPD and the PSS but back up first.

           

          Did you get my email pointing out the problem you had with image tips is fixed in Rh10?

           


          See www.grainge.org for RoboHelp and Authoring tips

           

           

          @petergrainge

          • 2. Re: RH10 Project wont save topics in Design view.
            rasterdan Community Member

            This project continues to degrade now with RH10.  I am now having trouble even getting this project to compile HTML Help.  I have deleted the cpd file with no help.  It seems to me that somewhere down the line that RH deleted and or replaced the cpd file  every time a project is opened.  Regardless, that is not the problem because deleting the file made no difference.

             

            I would like to try exporting this project and then importing it as a new project in the hope that some problems get sorted out.  We had a lot of global variables that got deleted and moved into a new project so maybe it is having issues figuring out the pointer for the few variables that are left.  The remaining variables were way down the list ... like #1000 or so.

             

            I may have to reinstall RH9 and remake the changes since the upgrade to RH10.  Overall, I am not happy with RH10, I have only had grief as a result of this upgrade.  We were hoping to make an Android app but so far, what time we have had to try that out has failed.

             

            Also, RH10 locks up frequently "stopped working" when the VPN or internet to my VPN connection is slow.  When it is fast, like early in the morning, I have fewer lockups.  Unfortunately, I must use this VPN and with RH9, I had NO problems with this.  No problems at all.  RH10 is killing me.  My colleague inside the building is having better luck but he has a desktop PC and a local network connection to the server.  Maybe the Adobe folks can look into this network issue.  I noticed in one of the other threads that someone else was having issues from a slow network.  This is what tipped me off to look in this direction and for sure, before my office on the west coast of the US opens, my project works a lot better.

             

            If there are any parameters I can change to modify the slow network issues with RH10 and the server, i would certainly be eager to try something.

            dv

            • 3. Re: RH10 Project wont save topics in Design view.
              Peter Grainge CommunityMVP

              Let's take this one by one.

               

              Automatic deletion of the CPD can be found in Tools > Options.

               

              There is no export option. You will need to create a new project and the folders you require. Then you can import all the topics within any one folder in one hit.

               

              I will email you direct some instructions for creating an APK file. They worked on three machines but not on a fourth machine.

               

              Rh10 was changed to allow it to work directly over a network. Whilst it is not my normal method of working, I have found that a little slower with some tasks but acceptable. Adobe do make the point that it is dependant on network speed so that could be why your colleague is OK as he is direct to the network. You are using VPN though so network speed could be more frustrating. When you say "lockup" does it recover and you just have to sit and wait or are you saying it crashes? Either way, I don't have an answer to this part but I can see if Adobe can provide any information.

               

              I wonder if you can find some time to work on one of the sample projects to see if you hit the same issues there? It would help pinpoint whether the issues are project or network related.

               


              See www.grainge.org for RoboHelp and Authoring tips

               

               

              @petergrainge

              • 4. Re: RH10 Project wont save topics in Design view.
                rasterdan Community Member

                Hello Peter, nice to hear from you again,

                 

                I just enabled the clear cpd file upon opening.  Haven't tested yet.  I did it manually yesterday along with PSS file.  No help.

                 

                I will keep the import a folder at a time in mind when we have more time to play with that.

                 

                Not sure what an APK file is so that will be interesting.

                 

                As for RH10 working on the network, we have been using it on the network since 2001.  Only since RH 9 have I seen any slow down with network check out/in and with RH10 and Win7 it is really having trouble with all of our projects that are in version control.  RH9 worked, just got slow where RH10 just stops working and when I say stops working, I left it overnight and it had not started working so it really stopped working.

                 

                Both my colleague and I have a problem project that locks up at the same place.  I turned the file where it stopped working into a snipped and placed into related topics.  The compile went about 12 topics further before locking up.  We went back to our RH9 version and it works just fine.  So there is something going on.  Also, this is the project where we have to switch to HTML view to save files.  We had this problem in RH9 initially and after clearing some formatting of a global variable, the project started working normally.

                 

                I attempted to do the same with the one variable we have and this did not change having to switch from design view to html view to save any topic.

                 

                I have converted a couple of my local topics to RH10 and they seem to work fine.  These are small in comparison to the big one that is having issues.  The big project compiles to 140Mb.

                 

                Is there a problem with more than 1000 files in the root of a project?  RoboHelp dumps photos into the root when you place an image.  I just left them there because when I need to update a photo or illustration, it overwrites and propagates through the book which is nice.  It also helps to keep from having duplicate images.  Almost all of the root images are .jpg files along with a few spread sheets, pdf files, and 6 swf files.  I attempted to move some out of the root to see if this helped but it did not change anything.

                 

                Ideas?

                • 5. Re: RH10 Project wont save topics in Design view.
                  rasterdan Community Member

                  I have figured out why topics won't save in design view but will save in HTML view.  When our project got upgraded the references to our global variable for "Revision_Current-Letter" were broken.  I went to each master page (14 in all) and deleted the global variable in the footer and replaced with the same variable but just a fresh itteration.  Then generated a topic properties report and found 3 topics that had this bogus variable link.  I replaced those links with a fresh one and suddenly I could save files in Design view again.

                   

                  So, very strange why Design view was blocking me from saving topics because a global variable was corrupted.  When I double clicked on the bogus variable, it came up empty.  I know this is a problem from having empty variables in the past.  I guess the Adobe folks have not fixed this issue about having a variable with no value!

                   

                  Hope this helps someone else.

                   

                  One more point, my project still will not compile HTML Help.  It makes Web Help but not HTML Help.  I think I have a lead but I am going to open a new discussion for that because it is has a strange double path problem. 

                   

                  dv