9 Replies Latest reply: Nov 25, 2013 8:36 AM by sinious RSS

    Stuck at publishing for andriod 4.3

    ZJ

      I get stucked when i tried to publish air for android 4.3 using flash cs6. No issue with android 4.1.2.

        • 1. Re: Stuck at publishing for andriod 4.3
          sinious CommunityMVP

          Can you elaborate on what you mean by publishing for 4.3? Are you trying to set something like android:minSdkVersion="4.3" or are you saying your APK does not work on 4.3 (are you on a Nexus?) but it does work back in 4.1.2 (what I still use on SGS)?

          • 2. Re: Stuck at publishing for andriod 4.3
            ZJ Community Member

            I'm trying to publish and test on device (samsung note 3) running android version 4.3. I had no issue testing on device (samsung note 2) running android version 4.1.2.

             

            a.jpg

             

            I get stuck at this publishing screen.

            b.jpg

            • 3. Re: Stuck at publishing for andriod 4.3
              sinious CommunityMVP

              I have quite a few issues in both Flash and Flash Builder with MTP devices. I know it's not convenient but uncheck "Install application on the connected Android device", produce the APK, then copy it over using your standard filesystem. You should have an app called something like "My Files". Open it, choose "All Files" and your APK will be where you put it. Click to install it.

               

              I have a Samsung Galaxy S3 (4.1.2) that works perfectly device testing over USB and with installs. I have a Samsung Galaxy Tab 3 8.0" running 4.2.2 that refuses to let me USB debug and will hang if I leave that option checked. I installed all device drivers I could find, absolutely everything. ADB tells me the device is stuck on "authorizing" which means when you toggle USB Debugging it should get a RSA cert from the PC and ask you if it's ok to debug with the connected computer. On my device this dialog never came up, ever, after toggling it a million times. 'adb devices' continues to show me the device listed as 'unauthorized'.

               

              I gave up and I just test on other devices (Sony Xperia Tablet Z works perfect, so does SGT 2 7.0", so does my phone, ASUS Transformer, etc etc). I've found a huge amount of issues integrating Samsungs 4.2.2 and up devices.

              • 4. Re: Stuck at publishing for andriod 4.3
                ZJ Community Member

                Same here, i updated all drivers, softwares, plug/unplug device, toggle usb debugging, change usb port and tried all solutions found on web including those on adobe and android etc and still can't get it to work...

                 

                guess will have to install it manually by copying the apk file over...

                • 5. Re: Stuck at publishing for andriod 4.3
                  Veena S

                  Hi,

                   

                  Can you please let me know, if you are using Flash Professional CS6 or Flash Professional CC. Also, please let me know the version of the Flash professional that you are using.

                   

                  Regards,

                  Veena

                  • 6. Re: Stuck at publishing for andriod 4.3
                    ZJ Community Member

                    I'm using Adobe Flash Professional CS6 Version 12.0.2.529 (AIR 3.4) on Windows 7 64-bit OS. The device is running on Android version 4.3.

                    • 7. Re: Stuck at publishing for andriod 4.3
                      TavaresEd

                      I was having this issue but I unchecked install and I install it by copying the apk to my SD Card and run the apk intaller.

                      • 8. Re: Stuck at publishing for andriod 4.3
                        Veena S Community Member

                        Please try with Flash Professional CC, you should not see this issue.

                        • 9. Re: Stuck at publishing for andriod 4.3
                          sinious CommunityMVP

                          The issue has to do with the devices status to adb than the version of Flash used. At most Flash may realize the install of AIR or the copy process is failing while it handles that situation but the real issue at hand is the device itself isn't allowing the user to specify the computer it's attached to is "authorized" to install content on it.

                           

                          This is really only for a small set of devices but it's becoming increasingly noticable that 4.2.2 and up devices are currently affected by it. I'm sure a driver or firmware update will resolve this in the near future.

                           

                          Copying the APK manually isn't too hard over MTP.