1 Reply Latest reply on Apr 21, 2014 1:24 AM by paolosini

    Could not save preferences because the file is locked...

    alextomato

      When I import new brushes/patterns/etc. into photoshop, they import fine and work fine. However, when I go to quit photoshop, I receive an error message that reads as follows:

       

      Screen Shot 2013-11-19 at 4.59.03 AM.png

      When I reopen photoshop after this, the brushes and patters I previously opened with photoshop are not there.

       

      I have looked through this forum and saw another user having a similar issue; Their issue was resolved by right clicking on photoshop in the applications folder, clicking "Get Info," and then changing the permissions so the user account they were using was set as the owner. I have already done that, but I am still receiving this message. I thought maybe it was that the brushes I was using were also not set for me to be able to read and write; I right clicked on them and made sure the permissions were set to my account. That didn't work either.

       

      I am using OSX Mavericks and Photoshop CS5.

        • 1. Re: Could not save preferences because the file is locked...
          paolosini

          I had the same problem after migrating from Snow Leopard to Mavericks.

          After reading here and on other forums similar complaints and partial solutions, here is how I solved the problem on my machine.

           

          The file that PS cannot update is "~/Library/Preferences/Adobe Photoshop CS5 Settings/Adobe Photoshop CS5 Prefs.psp"

          Although the user has read and write access, it cannot be modified because the user has no write access to the above directory.

           

          The quickest way to fix this is:

          1. open a Finder window

          2. go to  "~/Library/Preferences/Adobe Photoshop CS5 Settings" by typing Shift-Cmd-G and pasting the path between quotes (see Note 2 for details)

          3. get info (Cmd-i or right click -> Get info)

          4. in the "Sharing & Permissions" section, change the Privilege for "everyone" from "Read only" to "Read & Write"

           

          Note 1: to perform step 4 you first need to open the padlock on the lower right by clicking on it and enter an administrator's username and password

          Note 2: in Mavericks, the ~/Library directory is hidden by default, so either you perform step 2 by jumping straight to it or you press the Alt key to make it visible when you're descending the directory tree via the Go command on the menu bar