4 Replies Latest reply on Mar 16, 2011 5:49 PM by maruchi70

    CFDocument is broken in CF8 on my machine

    insuractive Level 3
      I recently set up a new workstation and decided to install CF8 on it. I had previously been working with CF7, and everything had been running correctly on my development machine. Now whenever I try to generate a PDF using <cfdocument> I get the following error:
      ------------------------------------------------------------------------------------------ -----------
      An exception occurred when performing document processing.

      The cause of this exception was that: java.lang.NoSuchMethodError: com.lowagie.text.pdf.PdfContentByte.createGraphics(FFFFLcom/lowagie/text/pdf/FontMapper;) Ljava/awt/Graphics2D;.

      The error occurred in C:\webroot\test.cfm: line 1

      1 : <cfdocument format="pdf">
      2 : test123
      3 : </cfdocument>

      ----------------------------------------------------------------------------------------- ------------

      Has anyone else had this error before? I've installed the latest hotfix for CF8, but no luck.

      The only other thing I can think of is I have another version of itext package installed on the server (becuase the version that shipped with CF7 was not the latest version and I needed some features from the newer iText version). The newer version is packaged as com/lowagie_new/ instead of com/lowagie to avoid conflicts with the version that shipped with CF7. The set up worked fine in CF7. I can even implement iText objects in CF8 and use them - its just the CF document functionality that is broken.

      I still get the same error when I try to run cfdocument if I remove the new iText package from the machine.

      Any suggestions would be greatly appreciated

      Thanks!