1 Reply Latest reply on Aug 4, 2006 9:17 AM by aglosband

    [Flex] RTMP-Server failed to start up

    Malcolm Edgar Level 1
      Hi All,

      I am trying to run Flex Data Services as a Tomcat 5.5.17 Server under Eclipse 3.1.2 WTP. When I start the server in Eclipse I get the following error:

      [Flex] RTMP-Server failed to start up: java.net.BindException: Address already in use: bind
      flex.messaging.endpoints.rtmp.RTMPException: The RTMP server has encountered a fatal exception starting up: Address already in use: bind
      at flex.messaging.endpoints.rtmp.BaseNIORTMPServer.run(BaseNIORTMPServer.java:310)
      at java.lang.Thread.run()V(Unknown Source)

      I have tried changing the services-config.xml RTMPChange port to about 10 different ports, and this hasn't resolved the issue:

      <channel-definition id="my-rtmp" class="mx.messaging.channels.RTMPChannel">
      <endpoint uri="rtmp://{server.name}:9876" class="flex.messaging.endpoints.RTMPEndpoint"/>

      When I run Tomcat outside of the Eclipse, this web application starts fine and no errors are logged.

      Other environment details are: Windows XP, JDK 1.4.2_10

      regards Malcolm Edgar
        • 1. Re: [Flex] RTMP-Server failed to start up
          aglosband Level 1
          You are only deploying one Flex web application on Tomcat? Maybe the web application is getting deployed twice for some reason.

          Have you tried looking at what ports are in use prior to starting the server in Eclipse? This might be a good sanity test. Running "netstat -a" will give you this on Windows.

          We usually see this when two web applications have the same channel configuration information by mistake. Not sure what is up in this case.