6 Replies Latest reply on Dec 2, 2013 2:38 PM by asydd

    App not installing on simulator after Xcode update

    ozy08

      I've just installed the latest Xcode updates and now when I test the App from Flash CC, it does not appear on simulator? The simulator launches OK however, my app icon does not appear. How can I fix this problem, it was working OK berfore I did the update?

        • 1. Re: App not installing on simulator after Xcode update
          asydd Level 1

          If you find an answer, please yell loudly !

          • 2. Re: App not installing on simulator after Xcode update
            meenat3

            Hi,

             

            Could you please let me know if you are able to find the installed app under following location: User/<username>/Library/Application Support/iPhone Simulator/7.0 folder.

             

            Please Quit the the Simulator and try deleting 7.0 folder. Then, repeat the process of installing tha app on iOS Simulator again. This time the app-icon should get visible.

             

            Let us know if this works for you.

             

            Regards,

            Meenakshi

            • 3. Re: App not installing on simulator after Xcode update
              ozy08 Level 1

              Hi

               

              I was unable to locate the folder

              User/<username>/Library/Application Support/iPhone Simulator/7.0 folder.

               

              There was no Library folder under my <username> however there was under the folder "Shared", but it did not have a "iPhone Simulator" folder.

               

              I did a "reset content and settings" which is a menu option in the ios simlator, however it did not correct the problem.

               

              The path to the ios simulator I am using is Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDK s/iPhoneSimulator7.0.sdk


              and this lauches OK with a version number of ios 7.0.3 displayed at the top.  However, my app icon still does not appear. 

               

              Shoud  the Library/Application Support/iPhone Simulator/7.0 folder path get created automatically when I run the simulator?

               

               

               

               


              • 4. Re: App not installing on simulator after Xcode update
                meenat3 Level 2

                Hi,

                 

                The path for iOS Simulator, you have provided is correct.

                 

                The Library folder is hidden, so please make sure the folder is not hidden. You could also try Go-> Go to Folder and then type ~/Library.

                 

                When the app is installed on iOS Simulator, it gets saved to the above said location:

                Library/Application Support/iPhone Simulator/7.0

                 

                Hence, please try deleting folder 7.0 and then install the app on iOS Simulator.

                 

                Let us know if this works for you.

                 

                Regards,

                Meenakshi

                • 5. Re: App not installing on simulator after Xcode update
                  ozy08 Level 1

                  Thanks, thats great, my app is now appearing in the simulator again!

                  • 6. Re: App not installing on simulator after Xcode update
                    asydd Level 1

                    Excellent - thank you for the info.

                    For a new Mac user it took a bit to get the hidden folders to show, couldn't follow your promt but found to use in Terminal:

                    defaults write com.apple.finder AppleShowAllFiles TRUE

                     

                    So now, yes the above worked and for the first time in months, iOS Simulator back on the road.

                     

                    Next question: I can't publish to the iPad, is there a similar resolve for OS X 9.5 and iOS 7.

                    First run through on the app I just put to the newly invigorated Simulator gave: Syd: Unable to install the application. Ensure that the selected devices are connected.

                    The device is connected, switched on and selected.