1 Reply Latest reply on Dec 3, 2013 3:12 AM by sjpt

    Digital edition password prob

    JulieLake

      My Digital Editions stopped working and prompted me for a password.  Couldn't find my password so requested a new one, as prompted.  New password activation link was sent to me by email.  I clicked on it.  Got a confirmation email.

      But when I tried to activate DE again, was told that the password was incorrect!

      BUT!  I have just logged into this site as a member with that password!

      I don't know what to do now to activate Digital Editions on my computer, which I need to download library ebooks to my ereader.

       

      JulieLake

        • 1. Re: Digital edition password prob
          sjpt Level 4

          I seem to remember somebody else having an issue with special characters in passwords,

          that the Adobe website would accept but ADE would not.

          It may be worth changing your password again, to something fairly feeble this time and seeing if that helps.

           

          added: just noticed another post on thread http://forums.adobe.com/thread/1111018?tstart=0

          I had the same problem with trying to Authorise an Adobe Vendor id. It took three changes of password to make it work - there seems to be a lag between creating the Adobe id and for it to be available to use to Authorise Digital Editions.

           

          Another thing to try is to use the older more reliable v1.7.2.

          I haven't hears of password issues with v2.0.x; but it has so many other bugs I wouldn't be suprised.

          ~~~~~~~~~

          There are lots of bugs in ADE2.0 (and 2.0.1).  Try replacing ADE2.0 with the older but more reliable v1.7.2.

          (You can have them both installed at once if you like.)

          Version 1.7.2, it is a little difficult to find, available on Adobe site for Windows and for Mac.

          http://helpx.adobe.com/digital-editions/kb/cant-install-digital-editions.html

          The forum software is sometimes corrupting the link above.  There shouldn't be a blank in 'editio ns.html'.  The following redirects to the same page: http://tinyurl.com/diged172

           

           

          Some people have found ADE trying to upgrade automatically. 

          It appears (not 100% sure) that if you install ADE2.0 as a new install (not as an upgrade) that your 1.7.2 will continue to run.

          Probably best to say no if 2.0.x installation asks if you want to migrate your library.