16 Replies Latest reply on Oct 15, 2008 1:30 AM by Peter Grainge

    Project will not generate

    Level 1
      I am new to Robohelp. Great software. I have been working on a project with no problems. Generating and viewing the results. Something has happened! I no longer can generate. I click generate and nothing happens. No error message or anything! What stupid mistake have I made?HELP! I have a deadline.
        • 1. Re: Project will not generate
          Peter Grainge Adobe Community Professional (Moderator)
          Welcome to the forum.

          Sorry for the slow reply. It sounds like you have been generating and now cannot, rather than you never have generated.

          Have you tried with another project? Create one or use one of the supplied samples. Is your project on your hard disk and are you generating to that?

          • 2. Re: Project will not generate
            Level 1
            I created a new project and tried to generate it. Yes, it is saved on the local disk. It still will not let me generate. When I tried to close the helpfile, I received a pop up saying: The following document needs to be saved. Helpfile.doc. Would you like Robohelp to save this document now? Options to choose are yes, yes to all, no, and cancel. The only way to close is to select no. However, looks like it is saving the project.
            • 3. Re: Project will not generate
              CynthiaCurl Level 1
              I have a similar problem. RoboHelp appears to generate my WebHelp file, but neither the View Results button nor any of the other View commands will display the generated application.
              • 4. Re: Project will not generate
                CynthiaCurl Level 1
                Here's the code that results when I try to generate a WebHelp file:
                ******************************************************************************************
                Starting compilation...
                WebHelp preprocessor 13.10.801

                Compiling C:\Documents and Settings\cynthia.curl\My Documents\RITMhelp\!SSL!\WebHelp\RITM.htm ...

                Preparing to create WebHelp...
                Clearing output folder...
                Preparing files for WebHelp...
                Copying files...
                Updating files...
                Finished preparing in 5 sec(s)

                Initializing compiler...
                Generating WebHelp 5.50 (13.10.801)...

                Template Active Script Error: (null) [Line: 13] (null)
                Template Error: can not resolve macro: RegisterResolvers

                Fatal Error: Cannot run macro: RegisterResolvers in compilation script.
                Template Error: can not resolve macro: WH_HOME_HTM
                Template Error: can not resolve macro: SF_HOMEPAGE_HTM
                Template Error: can not resolve macro: WH_CSH_HTM
                Template Error: can not resolve macro: WH_CSH2_HTM
                Finished compiling WebHelp in 5 sec(s)

                Compilation complete.
                *********************************************************************

                What do I need to do to get this fixed?
                • 5. Re: Project will not generate
                  RoboWizard Level 4
                  Hi CynthiaCurl and welcome to our community

                  First question I would have would be to ask if you have ever been able to successfully create WebHelp? I ask because I also see you are new here. So in my mind it's quite likely you have just installed RoboHelp. From what I've seen so far, it could easily indicate you don't have RoboHelp installed successfully. It has to be installed while you are logged in as yourself with administrator rights. Then you should run it first and after that, your IT folks may restrict you back to where you were.

                  Cheers... Rick
                  • 6. Project will not generate
                    CynthiaCurl Level 1
                    Thanks, Rick. I am a long-time RoboHelp user working with a WebHelp project that I created a year ago. I have been updating it successfully until recently when the Fatal Error message showed up. I don't think it's an installation issue, unless there is some built-in time bomb for version 5 users that would cause RoboHelp to crash once a new version hits the street! ;-) I am having our network support staff take a look at the errors to see if this is a permissions problem. Will post again with the results of that diagnostic.
                    • 7. Re: Project will not generate
                      Peter Grainge Adobe Community Professional (Moderator)
                      Has your version of Word been upgraded?

                      • 8. Re: Project will not generate
                        Level 1
                        My project was created on Office 2003. We upgraded company wide in December to 2007. Ever since, my project will not save or generate.
                        • 9. Re: Project will not generate
                          Peter Grainge Adobe Community Professional (Moderator)
                          Unless you have RH7, RH will not work with Office 2007.

                          • 10. Re: Project will not generate
                            HKabaker Level 2
                            ... And after installing a new version of Word, you have to re-install RH.

                            Can you get permission to re-install Word 2003 in addition to 2007?

                            Re-install Word 2003 and un/re-install RH 5.

                            Harvey
                            • 11. Re: Project will not generate
                              Level 1
                              I have RH7. I created my project with Office 2003. Then upgraded to Office 2007. No, I can not have Word 2003 reinstalled.
                              • 12. Re: Project will not generate
                                RoboColum(n) Level 5
                                You need to uninstall/reinstall RH& to pick up the fact that you have upgraded to Word 2007.
                                • 13. Project will not generate
                                  Widget King Level 2
                                  I am having this same problem. Here is my current standing:


                                  I am using RoboHelp 7.

                                  I'm creating WebHelp.

                                  I am using Word 2003 and haven't updated or re-installed it since putting RoboHelp on the system.

                                  I have been able to view the generated file beforehand


                                  This is the output I get when I go to File > Generate File Layout (Microsoft HTML Help)...

                                  -------------------------------- Layout : Microsoft HTML Help --------------------------------
                                  Starting compilation...
                                  Clearing output folder...
                                  Starting compilation...

                                  And does not progress beyond that.
                                  • 14. Re: Project will not generate
                                    Peter Grainge Adobe Community Professional (Moderator)
                                    Welcome to the forum

                                    You tell us of the problem but not what you have tried.

                                    Start by generating to a new folder.

                                    • 15. Re: Project will not generate
                                      Widget King Level 2
                                      The same thing happens.

                                      It seems to only be a problem with this particular word doc. If delete all the topics that have been taken from the word doc out of the TOC and replace them with ones I have made, then it will let me view the output.
                                      • 16. Re: Project will not generate
                                        Peter Grainge Adobe Community Professional (Moderator)
                                        I would make a copy of the project and then delete half the topics and try again. If the problem persists, delete half of what is left and so on.

                                        Eventually you will track a batch of topics wherein the problem lays and you will be able to continue the process until you do track it down.