2 Replies Latest reply on Dec 21, 2007 12:10 AM by Ivascu Cristian

    Compiling error!  Need HELP!!!!

    JohnLeger Level 1
      I am using the lastest Flex 3 beta 3 release. Why does the compiling error point to the flex2gateway in the URL below? Is this normal? If not what should it be and where do I change it?

      I see this same URL in my services-config.xml in the flex directory in my wwwroot.

      This is the error message I get when I open the release version of my Main.html file...

      [RPC Fault faultString="Send failed" faultCode="Client.Error.MessageSend" faultDetail="Channel.Connect.Failed error NetConnection.Call.Failed: HTTP: Status 404: url: ' http://localhost/flex2gateway/'"
      at mx.rpc::AbstractInvoker/ http://www.adobe.com/2006/flex/mx/internal::faultHandler()
      at mx.rpc::Responder/fault()
      at mx.rpc::AsyncRequest/fault()
      at mx.messaging::ChannelSet/faultPendingSends()
      at mx.messaging::ChannelSet/channelFaultHandler()
      at flash.events::EventDispatcher/dispatchEventFunction()
      at flash.events::EventDispatcher/dispatchEvent()
      at mx.messaging::Channel/connectFailed()
      at mx.messaging.channels::PollingChannel/connectFailed()
      at mx.messaging.channels::AMFChannel/statusHandler()


      Here's the services-config.xml code...

      <?xml version="1.0" encoding="UTF-8" ?>
      - <services-config>
      - <services>
      <service-include file-path="remoting-config.xml" />
      <service-include file-path="proxy-config.xml" />
      <service-include file-path="messaging-config.xml" />
      <service-include file-path="data-management-config.xml" />
      </services>
      - <security>
      <login-command class="flex.messaging.security.JRunLoginCommand" server="JRun" />
      - <!--
      Uncomment the correct app server
      <login-command class="flex.messaging.security.TomcatLoginCommand" server="Tomcat"/>
      <login-command class="flex.messaging.security.WeblogicLoginCommand" server="Weblogic"/>
      <login-command class="flex.messaging.security.WebSphereLoginCommand" server="WebSphere"/>


      -->
      - <!--
      <security-constraint id="basic-read-access">
      <auth-method>Basic</auth-method>
      <roles>
      <role>guests</role>
      <role>accountants</role>
      <role>employees</role>
      <role>managers</role>
      </roles>
      </security-constraint>


      -->
      </security>
      - <channels>
      - <!-- CF Based Endpoints
      -->
      - <channel-definition id="my-cfamf" class="mx.messaging.channels.AMFChannel">
      <endpoint uri=" http://{server.name}:{server.port}{context.root}/flex2gateway/" class="flex.messaging.endpoints.AMFEndpoint" />
      - <properties>
      <polling-enabled>false</polling-enabled>
      - <serialization>
      <instantiate-types>false</instantiate-types>
      </serialization>
      </properties>
      </channel-definition>
      - <channel-definition id="cf-polling-amf" class="mx.messaging.channels.AMFChannel">
      <endpoint uri=" http://{server.name}:{server.port}{context.root}/flex2gateway/cfamfpolling" class="flex.messaging.endpoints.AMFEndpoint" />
      - <properties>
      <polling-enabled>true</polling-enabled>
      <polling-interval-seconds>8</polling-interval-seconds>
      - <serialization>
      <instantiate-types>false</instantiate-types>
      </serialization>
      </properties>
      </channel-definition>
      - <channel-definition id="my-cfamf-secure" class="mx.messaging.channels.SecureAMFChannel">
      <endpoint uri="https://{server.name}:{server.port}{context.root}/flex2gateway/cfamfsecure" class="flex.messaging.endpoints.SecureAMFEndpoint" />
      - <properties>
      <polling-enabled>false</polling-enabled>
      - <serialization>
      <instantiate-types>false</instantiate-types>
      </serialization>
      </properties>
      </channel-definition>
      - <!-- ColdFusion specific RTMP channel
      -->
      - <!--
      <channel-definition id="cf-rtmp" class="mx.messaging.channels.RTMPChannel">
      <endpoint uri="rtmp://{server.name}:2048" class="flex.messaging.endpoints.RTMPEndpoint"/>
      <properties>
      <idle-timeout-minutes>20</idle-timeout-minutes>
      <serialization>
      <instantiate-types>false</instantiate-types>
      </serialization>
      </properties>
      </channel-definition>


      -->
      - <!-- Java Based Endpoints
      -->
      - <!--
      <channel-definition id="java-amf" class="mx.messaging.channels.AMFChannel">
      <endpoint uri=" http://{server.name}:{server.port}{context.root}/flex2gateway/amf" class="flex.messaging.endpoints.AMFEndpoint"/>
      </channel-definition>

      <channel-definition id="java-secure-amf" class="mx.messaging.channels.SecureAMFChannel">
      <endpoint uri="https://{server.name}:{server.port}{context.root}/flex2gateway/amfsecure" class="flex.messaging.endpoints.SecureAMFEndpoint"/>
      </channel-definition>

      <channel-definition id="java-polling-amf" class="mx.messaging.channels.AMFChannel">
      <endpoint uri=" http://{server.name}:{server.port}{context.root}/flex2gateway/amfpolling" class="flex.messaging.endpoints.AMFEndpoint"/>
      <properties>
      <polling-enabled>true</polling-enabled>
      <polling-interval-seconds>8</polling-interval-seconds>
      </properties>
      </channel-definition>

      <channel-definition id="java-rtmp" class="mx.messaging.channels.RTMPChannel">
      <endpoint uri="rtmp://{server.name}:2036" class="flex.messaging.endpoints.RTMPEndpoint"/>
      <properties>
      <idle-timeout-minutes>20</idle-timeout-minutes>
      </properties>
      </channel-definition>


      -->
      - <channel-definition id="java-http" class="mx.messaging.channels.HTTPChannel">
      <endpoint uri=" http://{server.name}:{server.port}{context.root}/flex2gateway/http" class="flex.messaging.endpoints.HTTPEndpoint" />
      </channel-definition>
      - <channel-definition id="java-secure-http" class="mx.messaging.channels.SecureHTTPChannel">
      <endpoint uri="https://{server.name}:{server.port}{context.root}/flex2gateway/httpsecure" class="flex.messaging.endpoints.SecureHTTPEndpoint" />
      </channel-definition>
      </channels>
      - <logging>
      - <target class="flex.messaging.log.ConsoleTarget" level="Error">
      - <properties>
      <prefix>[Flex]</prefix>
      <includeDate>false</includeDate>
      <includeTime>false</includeTime>
      <includeLevel>false</includeLevel>
      <includeCategory>false</includeCategory>
      </properties>
      - <filters>
      <pattern>Endpoint.*</pattern>
      <pattern>Service.*</pattern>
      <pattern>Configuration</pattern>
      <pattern>Message.*</pattern>
      </filters>
      </target>
      </logging>
      - <system>
      <manageable>false</manageable>
      - <!--

      <redeploy>
      <enabled>true</enabled>
      <watch-interval>20</watch-interval>
      <watch-file>{context.root}/WEB-INF/flex/services-config.xml</watch-file>
      <watch-file>{context.root}/WEB-INF/flex/proxy-config.xml</watch-file>
      <watch-file>{context.root}/WEB-INF/flex/remoting-config.xml</watch-file>
      <watch-file>{context.root}/WEB-INF/flex/messaging-config.xml</watch-file>
      <watch-file>{context.root}/WEB-INF/flex/data-management-config.xml</watch-file>
      <touch-file>{context.root}/WEB-INF/web.xml</touch-file>
      </redeploy>


      -->
      </system>
      </services-config>


      NOTE: I am also using ColdFusion 8 Developer Edition with the build in server. Any help would be appreciated.