3 Replies Latest reply on Dec 19, 2007 3:33 AM by Newsgroup_User

    File not found: flashplayer

    Ilikeprivacy
      Firstly, thanks Adobe for working towards releasing Flexbuilder for Linux! I'm quite happy without the visual FlexBuilder.

      I'm running build 3.0.190768 with Eclipse 3.3.1.1 and java 1.6.0 on Ubuntu Feisty Fawn. It works beautifully! My only issue is that I prefer testing my apps using flashplayer rather than in browser (it's quicker). I very much doubt it makes much of a difference though I'm developing an Actionscript project.

      When I configure my project to not generate a html file it tries to launch in the flashplayer however I receive an alert saying "File not found: flashplayer" and I can't for the life of me get it to find this file (it is sitting in ~/Adobe_Flex_Builder_Linux/Player/linux/flashplayer and works if I run from a shell). I've tried adding it to the path and everywhere else that I could think of.

      Any help would be greatly appreciated.
        • 1. Re: File not found: flashplayer
          Level 7
          Ilikeprivacy wrote:
          > Firstly, thanks Adobe for working towards releasing Flexbuilder for Linux! I'm
          > quite happy without the visual FlexBuilder.
          >
          > I'm running build 3.0.190768 with Eclipse 3.3.1.1 and java 1.6.0 on Ubuntu
          > Feisty Fawn. It works beautifully! My only issue is that I prefer testing my
          > apps using flashplayer rather than in browser (it's quicker). I very much doubt
          > it makes much of a difference though I'm developing an Actionscript project.
          >
          > When I configure my project to not generate a html file it tries to launch in
          > the flashplayer however I receive an alert saying "File not found: flashplayer"
          > and I can't for the life of me get it to find this file (it is sitting in
          > ~/Adobe_Flex_Builder_Linux/Player/linux/flashplayer and works if I run from a
          > shell). I've tried adding it to the path and everywhere else that I could think
          > of.
          >
          > Any help would be greatly appreciated.
          >
          >
          It works fine for me.
          Can you echo $PATH and see what it contains?
          if you are able to launch via terminal ($>flashplayer) after setting the
          path, then it should work all fine from flex builder too..
          Is any one else encountering it?

          Can you try this?
          $>export LD_LIBRARY_PATH =
          $HOME/Adobe_Flex_Builder_Linux/Player/linux/flashplayer

          and launch FB and see if it works?

          ~ Arun
          • 2. Re: File not found: flashplayer
            Ilikeprivacy Level 1
            Hi Arun,

            Thanks for your quick reply!

            I assume the library path isn't correctly exported on the install though does get correctly configured upon a reboot as it works perfectly after I restarted my machine.
            • 3. Re: File not found: flashplayer
              Level 7
              Ilikeprivacy wrote:
              > Hi Arun,
              >
              > Thanks for your quick reply!
              >
              > I assume the library path isn't correctly exported on the install though does
              > get correctly configured upon a reboot as it works perfectly after I restarted
              > my machine.
              >
              >
              I dont think that should be an issue... But not sure though !
              $>export PATH=$HOME/Adobe_Flex_Builder_Linux/Player/linux/flashplayer
              $>eclipse
              should do.. This is how i do it everytime..
              And if you are using an inbuilt script to launch Flex builder, it
              actually sets this path variable...

              Finally, good to hear that your problem is solved...

              ~ Arun