10 Replies Latest reply on Jun 3, 2014 3:44 PM by asonoftheAlmighty

    How can I get the keyboard program InKey to work with InDesign?

    asonoftheAlmighty

      I use InKey to type special characters, particularly underlined vowels, for another language. This has worked fine in Microsoft Word with most Unicode fonts. However in InDesign, the underlines do not line up under the letter; or, more commonly, they just display as a pink space or box after the letter. Simply using the Underline format on these letters is not sufficient to be able to check their spelling.

        • 1. Re: How can I get the keyboard program InKey to work with InDesign?
          Fede Gianni Level 3

          are you using a font that includes the character?

           

          open the glyphs panel and look, because pink squares can be for missing characters.

           

          can you show me a picture of the character you want?

          • 2. Re: How can I get the keyboard program InKey to work with InDesign?
            asonoftheAlmighty Level 1

            Here is a screen shot of how the underlined vowels appear in Word.

            Underlined vowels.PNGThis is with Times New Roman font. They may appear just like a vowel with an underline format, but actually if they would be formatted underlined, the underline would appear just below this underline and a little longer. So far I have not found these characters under glyps in any font in Design.

            • 3. Re: How can I get the keyboard program InKey to work with InDesign?
              Joel Cherney Adobe Community Professional & MVP

              I'm not too familiar with InKey - I'm a Tavultesoft Keyman guy from way back - but I know the basic class of applicaiton you're talking about, and have a few questions and suggestions.

               

              First off: what version of InDesign are you using? I've seen reports that combining Unicode diacritics are not working in InDesign CC, which I think of as completely unforgiveable. But then again I'm the Wierd Language Typesetting Guy so of course I think that. So if you're on CC you may have to just roll back to CS6, or wait.

               

              I know that those combining glyphs are available in Times New Roman, among others, but I don't know of any fonts off the top of my head that have those precomposed glyphs built in. You could fake it with an underline, of course, but I suspect that you already know that, and have rejected the possibility.

               

              For the occasions when the combining underline does not line up correctly, but does appear - do you have Optical Kerning turned on? Turn it off, and use the font's built-in metrics.

               

              Lastly - if using InKey does not work, does it work from the Glypsh panel? That is, keying a lowercase e with the en_US keyboard built into your OS, then using the InDesign GLyphs panel to navigate to the section of the font that has the combining glyphs, and then double-clicking on your combining underscore to insert it. If that works, but using InKey doesn't, then you should probably talk to the InKey developers. At least they should be told that their wiki is down, because I suspect that this is not a problem with InKey, but the actual build of the keyboard that you are using. Did you make it yourself?

              1 person found this helpful
              • 4. Re: How can I get the keyboard program InKey to work with InDesign?
                Fede Gianni Level 3

                i can't get the undescore in any vowel, only in a few consonants, you first need to find a character set that contains the underscored vowels, then you just use the option+h followed by the letter you want.

                 

                what language is?

                Screen shot 2013-12-05 at 12.35.04 .png

                • 5. Re: How can I get the keyboard program InKey to work with InDesign?
                  asonoftheAlmighty Level 1

                  Ok, I am using CC so that is probably my problem.Currently I just have the 30 day free trial of it. Is there a way that I can download the free trial of CS6 or CS5.5 to see if that fixes my problem? or how soon will they be correcting this in CC?

                  • 7. Re: How can I get the keyboard program InKey to work with InDesign?
                    Joel Cherney Adobe Community Professional & MVP

                    or how soon will they be correcting this in CC?

                     

                    You know, I went looking for the thread where I saw this reported, and I found that my memory was incorrect. Steve speculated that it was a bug in CC, but it's not like an Adobe staff member said something about it.

                     

                    For what it's worth, I just went into InDesign CC, hammered out some fake Latin-script text, and then added combining macron below. It worked fine in Times New Roman, once I'd turned off Optical Kerning. So there must be other variables here that are causing your setup to fail. Have you tried inserting with the Glyphs menu? Just to test, you know - I'm not suggesting that you change your workflow. Your keyboard may need some work, though.

                     

                    Also, nice to see I'm not alone wondering "which language has these glyphs?"

                    • 8. Re: How can I get the keyboard program InKey to work with InDesign?
                      asonoftheAlmighty Level 1

                      Ok, if I understand the kerning correctly on the top toolbar I can choose the kerning to be Optical, Metrics, or a number value. None of these options seem to make any difference in the way underlines work. And where do I find the "combining macron below?" I do not see it anywhere under glyphs. However my glyphs panel does have about 200 selections that appear just as boxes. When I hold my cursor over them, it does give each one a name and even through all those I do not find a "combining macron below." But then again those names might not be accurate; a lot of them say "NULL". I can use the combining macron below in Word, and it does look like that is what I need.

                         Do I not have all the correct fonts?

                         To satisfy your curiosity I am trying to type K'ekchi', an indigenous language of Guatemala. Although it can be spelled with a completely different phonetic system, the system we use uses underlined vowels.

                       

                      Now I just did some more tests, and discovered that the underlines do display correctly with Times New Roman font, but only if it is bold, italics or both. With Arial, italics doesn't fix it but bold does.

                      • 9. Re: How can I get the keyboard program InKey to work with InDesign?
                        Joel Cherney Adobe Community Professional & MVP

                        Oh, cool! I never handle any Mayan stuff in my job, but many of my academic cohort have done so. Mostly Tzotzil.

                         

                        Anyhow: your sample font was Times New Roman. If you can't see the combining glyphs, then you're using an out-of-date version of the font, or something else is wrong. . Did you maybe start your work on a contemporary version of Word in WIndows, and now you've shifted to using a Mac with an older version of Office? THere are plenty of nulls in TNR (which are usually codepoints not in Unicode, usually a sign of some kind of hacky workaround on the part ofthe font designer). There should be a real combining macron below right about here, in between the crazy upper Latin and the Greek caps :

                         

                        glyph.png

                         

                        So I'd want to know: what font are you using for this? If not TNR, then I'd suggest Gentium. I might even suggest dropping TNR for Gentium. Judging by your screen name, you may well already be aware of SIL. If not - oh hey, they make fonts for people who are in your shoes! Go check 'em out. The fonts are free, and pretty reliable. And Gentium may already have a precomposed with-line-below glyph for your typesetting needs.

                         

                        The Kerning dropdown lets you adjust the spacing between letters in a letter-by-letter way. Selecting all of your text and picking "Metrics" is the way to go here - unless you are a designer who thinks that the capital D is way too far away from the lowercase i, and want to tweak the kerning manually. "Optical" is for large font sizes where body-text-style kerning is too spacious. Avoid using it at small font sizes.

                        • 10. Re: How can I get the keyboard program InKey to work with InDesign?
                          asonoftheAlmighty Level 1

                          Sorry that I dropped the thread for so long. I thought maybe although it is so long, I could at least tell the outcome. Yes, I am familiar with SIL and it was a representative from them that helped me get set up with InKey and spell checking in K'ekchi'. Through contacting him again, I still could not figure out why the underlined vowels don't display correctly, but he did say that even with the correct letters the spell check will not work with InDesign. We eventually decided to simply stick with Word and leave InDesign. Thank you for your help, though. It might be a problem I'll need to take up again later if I ever switch to InDesign.