3 Replies Latest reply on Dec 5, 2013 12:18 PM by Steve Werner

    Smart text reflow not working

    Am05 Level 1

      I can't get the smart text reflow to work. I have my preferences set to Master Text Frame and Smart Text Reflow. I do NOT have text to import, but rather I am trying to copy and paste text into my page frame box from another InDesign document.

       

      The reason I am copying and pasting my text is because I want all of my paragraph/character styles to import into this new document without having to do them over again.

       

      The Smart Text Reflow is not creating new pages and there is overset text in the page document.

       

      I don't know what I am doing wrong! Help!

       

      InDesign CS5

        • 1. Re: Smart text reflow not working
          Salah Fadlabi Level 5

          When create a new document check on: Primary Text Frame on New Document dailog box.

          • 2. Re: Smart text reflow not working
            Sandee Cohen Adobe Community Professional

            I'm going to try to help you with Smart TextReflow, but before I get into that, did you know that you can import all the paragraph and character styles from one document to another without having to copy/paste.

             

            Go to the Paragraph Styles panel, and choose Load All Text Styles from the menu. Now the new document has all the styles.

             

            Now, as to why Smart TextReflow isn't working, are you sure you're working on the master text frame?

             

            Copy the text to the clipboard you want to flow.

             

            Create the new document with a Master Text Frame. Make sure Smart TextReflow is turned on.

             

            Go to the first page.

             

            Cmd/Ctrl-Shift-click to release the master frame.

             

            Click with the Type tool to get a blinking cursor inside the frame.

             

            Paste.

             

            You should get more pages.

             

            If you now type in the story, the pages will add as necessary.

            • 3. Re: Smart text reflow not working
              Steve Werner Adobe Community Professional & MVP

              From the Help file:

               

              "By default, Smart Text Reflow is limited to master text frames — text frames that are on a master page. If the document includes facing pages, master text frames must appear on both left and right master pages, and the master text frames must be threaded for Smart Text Reflow to work.

              "You can change settings to allow pages to be added or removed when working in text frames that aren’t based on master pages. However, a text frame must be threaded to at least one other text frame on a different page for Smart Text Reflow to work."

               

              Are the frames you're pasting text into master frames? Are these Facing Pages? If so, are the master text frames on both left and right side, and have you threaded them?

               

              And, have you threaded your first page text frame to a second page before you start pasting?