4 Replies Latest reply on Dec 12, 2013 5:44 AM by nanojohn

    Director 12 (subscription) won't publish projector

    nanojohn Level 1

      I just purchased Director 12, subscription model, this morning. I am frustrated to say the least that it won't publish a simple projector on my system. It uses two xtras, BudAPI, and ImgXtra, but even if I remove them from the project, D12 still won't publish. It almost finishes, but bails about 90% through. System here is Win 7, 8Gb, D12. I've already reinstalled, and still get the same problem. Any clues on how to get D12 to publish a projector--not for IOS, rather for Windows.

      TIA,

      John

        • 1. Re: Director 12 (subscription) won't publish projector
          Milky_au Level 3

          more info needed - bails?

           

          did it : crash the computer - hang the program - close the program - return to director without creating projector - show error message?????

           

          did you try to make a 'small' test program - then try to make a projector????

           

          were you trying to update an older director file to D12. 

          ie. D8 to D12

           

          did you try removing ALL the xtras then save it with a different nane - then try to publish it????

           

          Are you using Buddy API 4.07

          • 2. Re: Director 12 (subscription) won't publish projector
            nanojohn Level 1

            Hi, and thanks for your reply. Here are the answers to your questions and comments:

             

            Did it crash the computer, hang or close D12?

              No. No crash, no hang. D12 did not close. Behavior is like this: Choose Publish from menu; D12 begins to compile 15 files, then suddenly stops at 14 and the progress bar disappears. D12 still functioning fine.

             

            Did I make a test program and try to publish?

              Yes. Same result.

             

            Did I update an older Director to D12?

              Yes. I updated from D11 to D12. All seemed to go well.

             

            Did I remove ALL xtras then save it with a different name then try to pubilsh?

              Yes. That was the first move I tried. Same result.

             

            Am I using BuddyAPI 4.07?

              Yes. I don't think that's the problem. I'm also using Valentin's "imgXtra" and it works fine in author mode.

             

            So overnight, I thought of something new to try and it seems to work. I reduced the User Account Controls to the lowest possible setting, opened D12, made a test program, and it published a projector just fine. So then I tried my project and it too published a projector just fine. So clearly, the UAC and D12 do not get along. The UAC probably thinks the the projector is compiling an exe that represents a threat to the system. If so, I wonder why no other Win 7 64 bit users of D12 have not reported this problem? Surely, I cannot be the only Win user with my UAC set to highest possible setting. Or is there some other factor in combination with the UAC that is prohibiting a projector compile? I don't know. It's rather strange that QA at Adobe didn't catch this oddity. Having worked in QA, I can tell you that we did test software with the UAC at various settings. But somehow this behavior slipped by Adobe QA.

             

            The bottom line is, I now must reduce my UAC to lowest possible setting, open D12 project, compile a projector, and reset my UAC to highest possible setting. How bizzare. BTW, I have no virus protection software on my machine other than Microsoft's Essential Security. Maybe that, plus UAC, prevents D12 from compiling projectors. Who knows. What a strange turn of events. Adobe should test this issue and correct it. Imagine if we all had to have our car passengers wait outside the car while we started the engine. Only then could passengers get into the car. And once the car was moving, the passengers would have to disembark at every stop light so the car wouldn't die.

             

            Thanks for your response,

            John

            • 3. Re: Director 12 (subscription) won't publish projector
              mklv

              nanojohns,

               

              I had a similar issue, and found a different workaround.

               

              Similar to you, I am using Director 12 (non-subscription) on Windows 7 Professional (64-bit), and publishing to a Windows projector.  I am also running Microsoft Security Essentials.

               

              I would select "Publish" and watch the projector executable being created in another Explorer window.  As soon as Director finished publishing, I noticed that the projector executable disappeared.

               

              I opened up Microsoft Security Essentials, went to the "Settings" tab.  Under the "Excluded files and locations", I added the folder where my Director project was stored, and then saved the settings.  After that, I was able publish a movie without issues.

               

              Ken

              • 4. Re: Director 12 (subscription) won't publish projector
                nanojohn Level 1

                Ken,

                   YES! That was excellent. It worked perfectly. I should have thought of that when I was playing around with the UAC. Your tip is most appreciated and it should be part of the D12 documentation!

                Happy Holidays,

                John